PAT-A 1028 List Sorting (25 分)

1028 List Sorting (25 分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

分析:水题,同样是25分的题,这题只是A1012的一部分,和A1016更是没法比。

#include <cstdio>
#include <string>
#include <vector>
#include <algorithm>

using namespace std;

typedef struct student
{
    int id;
    string name;
    int score;
    student(int i, string n, int s):id(i), name(n), score(s){}
}stu;

bool cmpById(stu a, stu b)
{
    return a.id < b.id;
}

bool cmpByName(stu a, stu b)
{
    if(a.name == b.name)
        return a.id < b.id;
    else
        return a.name < b.name;
}

bool cmpByScore(stu a, stu b)
{
    if(a.score == b.score)
        return a.id < b.id;
    else
        return a.score < b.score;
}
int main()
{
    int n, c;
    scanf("%d %d", &n, &c);

    vector<stu> all;
    int id;
    char name[9];
    int score;
    for(int i = 0; i < n; i++)
    {
        scanf("%d %s %d", &id, name, &score);
        all.push_back(stu(id, string(name), score));
    }

    if(c == 1)
        sort(all.begin(), all.end(), cmpById);
    else if(c == 2)
        sort(all.begin(), all.end(), cmpByName);
    else if(c == 3)
        sort(all.begin(), all.end(), cmpByScore);

    for(int i = 0; i < all.size(); i++)
    {
        printf("%06d %s %d\n", all[i].id, all[i].name.c_str(), all[i].score);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38127801/article/details/86475315
今日推荐