PAT 甲级1016 Phone Bills

题目描述

1016 Phone Bills (25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题目理解

我们需要记录所有的通话记录,不同时间段通话耗费

按姓名排序将有效通话按时间排序输出,并输出通话时长,耗费

对每个人再输出总的耗费

我们如果对每个人去计算他每段通话记录的时长,都在哪个时间段,再计算耗费,虽然可行但写起来繁琐

因此我们求出00:00到之后每一分钟的通话费用,再将00:00到每次通话开始或结束一共多少分钟记录则只需要将每次通话的结束时间耗费减去开始时间耗费即可

代码实现

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
const int M=24*60*31+10;
struct records
{
    int minutes;
    string state;
    string format_time;

    bool operator<(const records& t)const
    {
        return minutes<t.minutes;
    }
};
int main()
{
    //首先计算好从00:00到后面的每一分钟所需要的电话费
    int cost[25];
    for(int i=0;i<24;i++)
        cin>>cost[i];
    double sum[M];
    for(int i=1;i<M;i++)
        sum[i]=sum[i-1]+cost[(i-1)%1440/60]/100.0;
    int n;
    cin>>n;
    map<string,vector<records>>clients;//map来进行名字排序
    char name[25],format_time[15],state[10];
    int month;//后面要输出
    for(int i=0;i<n;i++)
    {
        int day,hour,minute;
        scanf("%s %d:%d:%d:%d %s",name,&month,&day,&hour,&minute,state);
        sprintf(format_time,"%02d:%02d:%02d",day,hour,minute);
        int minutes=(day-1)*1440+hour*60+minute;
        clients[name].push_back({minutes,state,format_time});
    }

    for(auto client:clients)
    {
        string name=client.first;
        vector<records> r=client.second;
        sort(r.begin(),r.end());

        double total=0;
        for(int i=0;i+1<r.size();i++)
        {
            records a=r[i],b=r[i+1];
            if(a.state=="on-line"&&b.state=="off-line")
            {
                if(!total)printf("%s %02d\n",name.c_str(),month);//第一个有效通话前输出名字月份
                cout<<a.format_time<<' '<<b.format_time<<' '<<b.minutes-a.minutes<<' ';//b.minutes-a.minutes为通话时长
                double money=sum[b.minutes]-sum[a.minutes];//通话开销
                printf("$%.2f\n",money);
                total+=money;
            }
        }
        if(total)
            printf("Total amount: $%.2f\n",total);
    }
    return 0;
}

おすすめ

転載: blog.csdn.net/m0_61974219/article/details/121155843