OpenWrt-WLAN-Setup

1. Aktivieren Sie die WLAN-Karte

Setzen Sie die Konfigurationsdatei zurück. Wenn es sich um ein neues System handelt, das noch nicht eingerichtet wurde, können Sie es überspringen

rm -f /etc/config/wireless; wifi config instead

Aktivieren Sie die drahtlose Netzwerkkarte

uci set wireless.@wifi-device[0].disabled="0"
uci commit wireless
wifi

Tipp: Hier wird die erste WLAN-Karte eingerichtet.
Wenn Sie eine zweite Netzwerkkarte einrichten möchten, gehen Sie wie folgt vor

uci set wireless.@wifi-device[1].disabled="0"
uci commit wireless
wifi wlan1

2. Drahtlose Netzwerkeinstellungen

Beim Ausführen iw devdes Befehls werden die folgenden Formatinformationen angezeigt

phy#0
        Interface wlan0
                ifindex 5
                wdev 0x1
                addr ab:12:23:dc:03:45
                type managed
                txpower 20.00 dBm

Suchen Sie nach einem drahtlosen Netzwerk

iw dev wlan0 scan

Zeigen Sie die Informationen zum drahtlosen Netzwerk im folgenden Format an. Wenn mehrere drahtlose Netzwerke vorhanden sind, werden mehrere Informationen in diesem Format angezeigt

BSS c8:d5:fe:c8:61:b0(on wlan0) 
        TSF: 24324848870 usec (0d, 06:45:24)
        freq: 2412
        beacon interval: 100 TUs
        capability: ESS (0x0411)
        signal: -72.00 dBm
        last seen: 140 ms ago
        Information elements from Probe Response frame:
        SSID: Violetta
        HT capabilities:
                Capabilities: 0x102c
                        HT20
                        SM Power Save disabled
                        RX HT20 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 32767 bytes (exponent: 0x002)
                Minimum RX AMPDU time spacing: 16 usec (0x07)
                HT RX MCS rate indexes supported: 0-7
                HT TX MCS rate indexes are undefined
        HT operation:
                 * primary channel: 13
                 * secondary channel offset: no secondary
                 * STA channel width: 20 MHz
        RSN:     * Version: 1
                 * Group cipher: CCMP
                 * Pairwise ciphers: CCMP
                 * Authentication suites: PSK
                 * Capabilities: 16-PTKSA-RC 1-GTKSA-RC (0x000c)

Bearbeiten /etc/config/network, hinzufügen und ändern Sie Folgendes

config interface 'wwan'
        option proto 'dhcp'

Bearbeiten /etc/config/wireless, hinzufügen und ändern Sie Folgendes

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'Violetta'
        option encryption 'psk2'
        option bssid 'c8:d5:fe:c8:61:b0'
        option key 'YourWifiPassword'

Bearbeiten /etc/config/firewall, Zone WAN suchen, Zeile hinzufügen list network 'wwan', wie folgt

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        list   network          'wwan'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

3. WLAN aktivieren

wifi; /etc/init.d/firewall restart

Informationen anzeigen

iw dev
phy#0
        Interface wlan0
                ifindex 5
                wdev 0x1
                addr ab:12:23:dc:03:45
                ssid Violetta
                type managed
                channel 13 (2472 MHz), width: 20 MHz, center1: 2472 MHz
                txpower 20.00 dBm

Je suppose que tu aimes

Origine blog.csdn.net/kangzeru/article/details/119606414
conseillé
Classement