【POJ-2234】Matches Game(尼姆博奕问题)

题意描述:有m堆石子,每堆石子个数是n,双方轮流从中取物品,每次取部分或全部,最多将该堆物品取完,最后取完物品的人赢,如果先手赢输出Yes,后手输出No.

解题思路:这是一道尼姆博奕问题,将每堆物品的数量异或起来,如果最后结果为零,则输出No,否则输出Yes。

结论:n 堆石子异或和不为 0 ,先手必胜,否则先手必输。 

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

AC代码 

#include<stdio.h>
#include<string.h>
int main()
{
	int a[25],n,i;
	while(~scanf("%d",&n))
	{
		int ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			ans=ans^a[i];
		}
		if(ans==0)
			printf("No\n");
		else
			printf("Yes\n");
	}
	return 0;
}

努力努力再努力

Supongo que te gusta

Origin blog.csdn.net/zz_xun/article/details/120224925
Recomendado
Clasificación