POJ1651 Multiplication Puzzle (search memory segment DP +)

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650 
finally encountered a comparison period DP of the water, the title and the best chain matrix multiplication is somewhat similar. First backwards analysis, certainly only three numbers, a number that is about two and a fixed number of the last remaining operating time of the last operation. As for the number of which to choose, it is necessary to enumerate left + 1 ~ right-1, which is the decision-making process, after the election, several considerations should come from how transfer, brain simulation about the process, will be able to launch transfer equation dp [l ] [r] = min (dp [l] [r], process (l, i) + process (i, r) + a [i] * a [l] * a [r]); recursively solving boundary length is a value of 0, then 2, then 3 values of the length a [l] * a [l + 1] * a [r], with a DP memory array. Finally, demand is dp [1] [n].
#include <the iostream> 
#include <cstdio> 
#include <CString>
 the using  namespace STD;
 int n-, A [ 105 ], DP [ 105 ] [ 105 ]; // last remaining left and right ends must be 
int Process ( int L, int R & lt) 
{ 
    IF (L + . 1 == R & lt) 
    { 
        DP [L] [R & lt] = 0 ;
         return  0 ; 
    } 
    IF (L + 2 == R & lt) 
    { 
        DP [L] [R & lt] = A [L] * a [l +1]*a[r];
        return dp[l][r];
    }
    int i;
    if(dp[l][r]!=0x3f3f3f3f)return dp[l][r];
    for(i=l+1;i<=r-1;i++)
    {
        dp[l][r]=min(dp[l][r],process(l,i)+process(i,r)+a[i]*a[l]*a[r]);
    }
    return dp[l][r];
 } 
int main()
{
    cin>>n;
    int i;
    memset(dp,0x3f3f3f3f,sizeof(dp));
    for(i=1;i<=n;i++)scanf("%d",&a[i]);
    cout<<process(1,n);
    return 0;
}

 

Guess you like

Origin www.cnblogs.com/lipoicyclic/p/12521572.html