HDU-1241,Oil Deposits(DFS)

Problem Description:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.  

Input:

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output: 

For each grid, output the number of distinct oil deposits. T 

Sample Input:

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0  

Sample Output:

0

1

2

AC Code: 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char a[101][101];
int m,n;
int dir[8][2]={{0,1},{0,-1},{1,0},{-1,0},
		{1,1},{-1,-1},{1,-1},{-1,1}};
bool judge(int x,int y)
{
	if(x>=0&&x<m&&y>=0&&y<n&&a[x][y]=='@')
		return true;
	return false;
}
void dfs(int x,int y)
{
	if(a[x][y]=='@')
		a[x][y]='*';
	for(int i=0;i<8;i++)
	{
		int tx=x+dir[i][0];
		int ty=y+dir[i][1];
		if(judge(tx,ty))
			dfs(tx,ty);
	}
	return ;
}
int main()
{
	while(cin>>m>>n)
	{
		if(!m||!n)
			break;
		int ans=0;
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				cin>>a[i][j];
		for(int i=0;i<m;i++)
		{
			for(int j=0;j<n;j++)
			{
				if(a[i][j]=='@')
				{
					dfs(i,j);
					ans++;
				}
			}
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

Published 302 original articles · won praise 313 · views 30000 +

Guess you like

Origin blog.csdn.net/weixin_43823808/article/details/104341676