Score obtained singer

Enter a positive integer n (n> 4), and then enter the real numbers n, determining the score singer (2 decimal places). There are n (n> 4) judges a singer singing a score is provided on the awards party scoring rules: Each in turn judges score, then remove the two highest and two lowest points, calculating the average scores for the remaining scores singer .

Input formats:

Input n-input n-th fraction in the second line in the first row

Output formats:

The average score in the output line

Sample input:

Here we are given a set of inputs. E.g:

10
10 10 9 9 9 8 8 8 7 7
 

Sample output:

Given here corresponding output. E.g:

aver=8.50
n = int(input())
lo = ([int(n) for n in input().split()])
lo.sort()
for i in range(0,4):
    num1 = lo.pop(-1)
    lo.reverse()
sum = 0
for j in range(len(lo)):
    sum += lo[j]
li = sum / len(lo)
print("aver={:.2f}".format(li))

  

Guess you like

Origin www.cnblogs.com/SkystarX/p/12334083.html
Recommended