PAT (Advanced Level) Practice 1062 Talent and Virtue (25 points) [sort]

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N ( 1 0 5 ) N (≤10^5) , the total number of people to be ranked; L ( 60 ) L (≥60) , the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H ( < 100 ) H (<100) , the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H H , but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L L line are ranked after the “fool men”.

Then N N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M ( N ) M (≤N) , the total number of people that are actually ranked. Then M M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

The meaning of problems

Germany gives N individual points and regrettably they require these people to sort.

  1. Sort in order of saint, a gentleman, a fool, a villain.
  2. Moral of not less than L will be sorted.
  3. H is not less than moral saint
  4. H is only less than a gentleman
  5. Moral and lower than H, but Germany is not only lower than the fool
  6. Are higher than the rest of the moral and L is the villain.
  7. Inside each person according to sorting out non-liter, if the same score are more divided Germany, if Germany is more points have the same ID.

Thinking

First classify these people, and then sorted.

Code

#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

struct st {
    char id[10];
    int v, t, cls, sum;
} sts[100005];

int main() {
    int n, l, h;
    scanf("%d %d %d\n", &n, &l, &h);

    int m = 0;
    for (int i = 0; i < n; ++i) {
        scanf("%s %d %d", sts[m].id, &sts[m].v, &sts[m].t);
        if (!(sts[m].v < l || sts[m].t < l)) {
            sts[m].sum = sts[m].v + sts[m].t;
            if (sts[m].v >= h && sts[m].t >= h)
                sts[m].cls = 1;
            else if (sts[m].v >= h && sts[m].t < h)
                sts[m].cls = 2;
            else if (sts[m].v < h && sts[m].t < h && sts[m].t <= sts[m].v)
                sts[m].cls = 3;
            else
                sts[m].cls = 4;
            ++m;
        }
    }

    sort(sts, sts + m, [](st &a, st &b) {
        if (a.cls != b.cls)
            return a.cls < b.cls;
        else if (a.sum != b.sum)
            return a.sum > b.sum;
        else if (a.v != b.v)
            return a.v > b.v;
        else
            return strcmp(a.id, b.id) < 0;
    });
    printf("%d\n", m);
    for (int i = 0; i < m; ++i)
        printf("%s %d %d\n", sts[i].id, sts[i].v, sts[i].t);
}
Published 184 original articles · won praise 19 · views 20000 +

Guess you like

Origin blog.csdn.net/Exupery_/article/details/104171772