HDU 2197 primitive strings (+ combinatorics inclusion and exclusion)

Description:

\quad by 0 0 and 1 1 sequence consisting of, the same can not be represented by a string of several connected smaller strings, called primitive string length of the number of n n < = 100000000 ) n(n<=100000000) primitive string?
answer m o d 2008 mod2008
, for example, 100100 100100 is not a primitive string, because he is composed of two 100 100 composition are primitive and 1101 series.
Input
\quad The input comprises a plurality of data, each row of data, including an integer n n , representative of the length of the string.

Output

\quad For each test case, output one line, the number of representatives to meet the requirements primitive string answer m o d 2008. mod2008.

Sample Input

1
2
3
4

Sample Output

2
2
6
12

Length of n n the 01 01 Total string is 2 n 2^n . Primitive strings required, as long as 01 01 Total non-primitive strings strings can lose it. Rather primitive string can be obtained from the native sequence.

easy, f [ n ] = 2 n ( f [ i ] ) 2 f[n]=2^n−∑(f[i])−2 , wherein i i was n n is greater than or equal 2 2 factors.

AC Code:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
    int ret = 0, sgn = 1;
    char ch = getchar();
    while (ch < '0' || ch > '9')
    {
        if (ch == '-')
            sgn = -1;
        ch = getchar();
    }
    while (ch >= '0' && ch <= '9')
    {
        ret = ret * 10 + ch - '0';
        ch = getchar();
    }
    return ret * sgn;
}
inline void Out(int a)
{
    if (a > 9)
        Out(a / 10);
    putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
    return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
    return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(int m, int k, int mod)
{
    ll res = 1, t = m;
    while (k)
    {
        if (k & 1)
            res = res * t % mod;
        t = t * t % mod;
        k >>= 1;
    }
    return res;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
    return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
    if (b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    int g = exgcd(b, a % b, x, y);
    int t = x;
    x = y;
    y = t - a / b * y;
    return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
    int d, x, y;
    d = exgcd(a, p, x, y);
    if (d == 1)
        return (x % p + p) % p;
    else
        return -1;
}

///中国剩余定理模板
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
    int M = 1, y, x = 0;
    for (int i = 0; i < n; ++i) //算出它们累乘的结果
        M *= a[i];
    for (int i = 0; i < n; ++i)
    {
        int w = M / a[i];
        int tx = 0;
        int t = exgcd(w, a[i], tx, y); //计算逆元
        x = (x + w * (b[i] / t) * x) % M;
    }
    return (x + M) % M;
}

map<ll, ll> mp;

ll solve(ll n)
{
    if (n == 1)
        return 2;
    if (mp[n])
        return mp[n];
    ll ans = 0;
    for (int i = 2; i * i <= n; i++)
    {
        if (n % i == 0)
        {
            ans = (ans + solve(i)) % 2008;
            if (i * i != n)
                ans = (ans + solve(n / i)) % 2008;
        }
    }
    ans = (qpow(2, n, 2008) - ans - 2 + 2008) % 2008;
    return mp[n] = ans;
}

int n;
int main()
{
    while (~sd(n))
    {
        mp.clear();
        mp[1] = mp[2] = 2;
        printf("%lld\n", solve(n));
    }
    return 0;
}
发布了611 篇原创文章 · 获赞 390 · 访问量 20万+

Guess you like

Origin blog.csdn.net/qq_43627087/article/details/103576177