AcWing 792. precision subtraction

AcWing 792. precision subtraction

Title Description

Given two positive integers, calculating their difference, the calculation result may be negative.

Input Format

A total of two rows, each row contains an integer.

Output Format

Total row containing the required difference.

data range

1≤ integer length ≤105

SAMPLE INPUT

32
11

Sample Output

21

Topic ideas

Low angle standard low memory, high memory subscript high; sequentially carry

#include<iostream>
#include<string>
#include<vector>
using namespace std;

bool cmp(vector<int> &A,vector<int> &B)
{
    if(A.size()!=B.size()) return A.size() > B.size();
    for(int i=A.size();i>=0;i--)
        if(A[i]!=B[i]) return A[i] > B[i];
    return true;
}

vector<int> sub(vector<int> &A,vector<int> &B)
{
    vector<int> C;
    for(int i=0, t=0; i<A.size(); i++)
    {
        t += A[i];
        if(i<B.size()) t -= B[i];
        C.push_back((t+10)%10);
        if(t>=0) t = 0;
        else t = -1;
    }
    while(C.size()>1 && C.back()==0) C.pop_back();
    return C;
}

int main()
{
    string a,b;
    cin >> a >> b;
    vector<int> A,B,C;
    for(int i=a.size()-1;i>=0;i--) A.push_back(a[i] - '0');
    for(int i=b.size()-1;i>=0;i--) B.push_back(b[i] - '0');
    
    if(cmp(A,B)) C = sub(A,B);
    else C = sub(B,A),printf("-");
    
    for(int i=C.size()-1;i>=0;i--) printf("%d",C[i]);
    
    return 0;
}

Guess you like

Origin www.cnblogs.com/fsh001/p/12242454.html