1027 Colors in Mars (20分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

Binary conversion, done twice, when practicing pure stl (actually a dish)

Source:

Low IQ people Star

#include<bits/stdc++.h>
using namespace std;
vector<int> Stack;
map<int,char> mp;
int main()
{
    mp[10]='A';mp[11]='B';mp[12]='C';
    int color;
    for(int i=0;i<3;i++)
    {
        cin>>color;
        Stack.clear();
        while(color!=0)
        {
            Stack.push_back(color%13);
            color/=13;
        }
        if(!i)cout<<'#';
        if(Stack.size()<2)
            cout<<'0';
        if(Stack.size()<1)
            cout<<'0';
        while(!Stack.empty())
        {
            int t=*(Stack.end()-1);
            if(t>9)
                cout<<mp[t];
            else
                cout<<t;
            Stack.pop_back();
        }
    }
}

Normal

#include<stdio.h>
char radix[15]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
int main(){
    int r,g,b;
    scanf("%d%d%d",&r,&g,&b);
    printf("#");
     
    printf("%c%c",radix[r/13],radix[r%13]);
    printf("%c%c",radix[g/13],radix[g%13]);
    printf("%c%c",radix[b/13],radix[b%13]);
    return 0;
}
Published 97 original articles · won praise 12 · views 2398

Guess you like

Origin blog.csdn.net/weixin_43301333/article/details/104091281