X-Plosives UVA - 1160 ---- disjoint-set + thinking

A secret service developed a new kind of explosive that attain its volatile property only when a specific
association of products occurs. Each product is a mix of two different simple compounds, to which we
call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds
creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three
compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.
You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive
binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in
the same room an explosive association. So, after placing a set of pairs, if you receive one pair that
might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you
must accept it.
An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,
F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the
following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).
Finally, you would accept the last pair, F+H.
Compute the number of refusals given a sequence of binding pairs.
Input
The input will contain several test cases, each of them as described below. Consecutive
test cases are separated by a single blank line.
Instead of letters we will use integers to represent compounds. The input contains several lines.
Each line (except the last) consists of two integers (each integer lies between 0 and 105
) separated by
a single space, representing a binding pair.
Each test case ends in a line with the number ‘-1’. You may assume that no repeated binding pairs
appears in the input.
Output
For each test case, the output must follow the description below.
A single line with the number of refusals.
Sample Input
1 2
3 4
3 5
3 1
2 3
4 1
2 6
6 5
-1
Sample Output
3

The meaning of problems: there are now have some compounds, each compound is different and is composed of two different integers, this condition exists when your hands:
hand at least N (N> 2), and compounds including N compounds containing exactly N different integers (i.e., each occurrence of which the integer N 2). So this time unstable compounds. For example, you have a compound (1,2), (2,3), (3,1) is so unstable, but if you only (1,2), (2,3) it is stable.
Now to give you all the compounds in the order, you have to ensure that the situation does not appear unstable compound, the number of output you need to reject the compound.
Input: multiple sets of instances. Each instance consists of a successive pair of integers (integer part of [0,10 ^ 5]). Between different instances of a blank line, there will be no repetition of the compounds, and -1 for a single line input end of the current instance.
Output: Output number you need to reject the compound.

Analysis: A ring prerequisite in FIG unstable compounds ----

So we just need to judge whether the segment of two compounds of elements appear in a Unicom component, if rejected.



#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN=100000+1000;
int pa[MAXN];
int findset(int x)
{
    if(pa[x]==x)return x;
    return pa[x]=findset(pa[x]);
}
void bind(int x,int y)
{
    int fa=findset(x);
    int fb=findset(y);
    pa[fa]=fb;
}
int main()
{
    int x,y;
    while(scanf("%d",&x)==1)
    {
        int sum=0;
        if(x==-1)
        {
            printf("0\n");
            continue;
        }
        scanf("%d",&y);
        for(int i=0;i<MAXN;i++)
            pa[i]=i;
        bind(x,y);
        while(scanf("%d",&x)==1&&x>=0)
        {
            scanf("%d",&y);
            int fa=findset(x);
            int fb=findset(y);
            if(fa==fb)//x与y已经是同一个连通分量了
                sum++;
            else
                bind(x,y);
        }
        printf("%d\n",sum);
 
    }
    return 0;
}

Published 289 original articles · won praise 6 · views 3936

Guess you like

Origin blog.csdn.net/qq_43690454/article/details/104066143