Shuffling Machine (20)

Shuffling Machine (20)

Time limit memory limit 1000 ms 65536 KB limit a code length determination program 100 KB Standard (from  small )

Title Description

Shuffling is a procedure used to randomize a deck of playing cards.
Because standard shuffling techniques are seen as weak, and in order to
avoid "inside jobs" where employees collaborate with gamblers
by performing inadequate shuffles, many casinos employ automatic
  shuffling machines
.  Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random
order and repeats for a given number of times.  It is assumed that the
initial status of a card deck is in the following order:

S1, S2, ..., S13, 

H1, H2, ..., H13, 

C1, C2, ..., C13, 

D1, D2, ..., D13, 

J1, J2

where "S" stands for "Spade", "H" for
"Heart", "C" for "Club", "D" for
"Diamond", and "J" for "Joker".  A given
order is a permutation of distinct integers in [1, 54].  If the number
at the i-th position is j, it means to move the card from position i to
position j.  For example, suppose we only have 5 cards: S3, H5, C1, D13
and J2.  Given a shuffling order {4, 2, 5, 3, 1}, the result will be:
J2, H5, D13, S3, C1.  If we are to repeat the shuffling again, the
result will be: C1, H5, S3, J2, D13.

Enter a description:

Each input file contains one test case.  For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times.  Then the next line contains the given order.  All the numbers in a line are separated by a space.

Output Description:

For each test case, print the shuffling results in one line.  All the cards are separated by a space, and there must be no extra space at the end of the line.

Input example:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Output example:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

 

Analysis: After [4,2,5,3,1] represents the reshuffle, the first card placed fourth position, the second card placed second position, a third card put the fifth position. . . , Saying the main use of the code.

// construct structures and sorting

#include <algorithm>
struct Node {
    int ID;
    String name;
} C [55], tmp; // generating structure

CMP BOOL (const Node X &, const Node & Y) {
    return x.id <y.id; // ascending
}
Sort (. 1 + C, C + +. 1 54 is, CMP); // Sort structure

AC Code:

#include<algorithm>
#include<iostream>
#include<sstream>
using namespace std;
struct node{
	int id;
	string name;
}c[55],tmp;
bool cmp(const node &x, const node &y) {
	return x.id < y.id;
}
void init(){	
	for(int i=1;i<=13;i++){
		stringstream ss;//int类型转string类型
		string s = "S";
		ss<<i;
		ss>>c[i].name;
		c[i].name = s + c[i].name;
		c[i].id=i;
	}
	for(int i=14;i<=26;i++){
		stringstream ss;
		string s = "H";
		ss<<i-13;
		ss>>c[i].name;
		c[i].name = s + c[i].name;
		c[i].id=i;
	}
	for(int i=27;i<=39;i++){
		stringstream ss;
		string s = "C";
		ss<<i-26;
		ss>>c[i].name;
		c[i].name = s + c[i].name;
		c[i].id=i;
	}
	for(int i=40;i<=52;i++){
		stringstream ss;
		string s = "D";
		ss<<i-39;
		ss>>c[i].name;
		c[i].name = s + c[i].name;
		c[i].id=i;
	}
	stringstream ss;
	string s = "J";
	ss<<1;
	ss>>c[53].name;
	c[53].name = s + c[53].name;
	c[53].id=53;

	stringstream ss1;
	ss1<<2;
	ss1>>c[54].name;
	c[54].name = s + c[54].name;
	c[54].id=54;
}
void print(){
	for(int i=1;i<=54;i++){
		cout<<c[i].name<<" ";
	}	
}

int main(){
	
	init();
	int n,x[55];
	cin>>n;
	for(int i=1;i<=54;i++){
		cin>>x[i];
	}
	for(int i=1;i<=n;i++){
		for(int j=1;j<=54;j++){
			c[j].id = x[j];
		}
		sort(c+1,c+54+1,cmp);
	}
	print();
	return 0;
} 

 

Published 67 original articles · won praise 14 · views 10000 +

Guess you like

Origin blog.csdn.net/weixin_38603360/article/details/97036259