Three Questions on the topic _ winter training solution _A - Cow Contest

topic

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

Subject to the effect

Given n cattle, each cow has a value of 1 to n, and different values ​​of any two cows, if they know the order of m values ​​of cattle, has a value of Q can be determined how many cows

answer

If ST [i] [j] is 0 for i, j uncertain relationship, 1 indicates a value larger than the i-j cow head, is smaller than j -1 indicates cow, the cow is the i-th value can conditions for determining ≠ i, for each k, st [i] [k] ≠ 0.

Code

#include <iostream>
#include <cstring>
using namespace std;
const int N = 110, M = 4510;
int  st[N][N];
 int main()
 {
 	memset(st,0,sizeof st);
 	int n,m;
 	cin >> n >> m;
 	for(int i = 1; i <= m; i ++)
 	{
 		int u, v;
 		cin >> u >> v;
 		st[u][v] = 1;
 		st[v][u] = -1;
 		for(int j = 1; j <= n; j ++)
 		{
		 	if(st[v][j]==1)
			{
			 	st[u][j] = 1;
			 	st[j][u] = -1;
			}
		 	if(st[u][j] == -1)
			{
			 	st[j][v] = 1;
			 	st[v][j] = -1;
			}
		}
	}
	for(int i = 1; i <= n; i ++)
	for(int j = 1; j <= n; j ++)
		if(st[i][j] == 0)
		for(int k = 1; k <= n; k ++)//通过k能够把i、j关系确定
		{
			if(st[i][k] == 1 && st[k][j] == 1)
			st[i][j] = 1,st[j][i] = -1;
			if(st[j][k] == 1 && st[k][i] == 1)
			st[j][i] =1,st[i][j] = -1;
		}
	int ans = 0;
	for(int i = 1; i <= n; i ++)
	{
		bool flag = true;
		for(int j = 1; j <= n; j++)
			if(st[i][j]==0&&i!=j)flag = false;
		if(flag)ans++;	
	}
	cout << ans;
	return 0;
 }

important point

1 can be determined by the k i, j relationship

Published 22 original articles · won praise 0 · Views 359

Guess you like

Origin blog.csdn.net/m0_46185124/article/details/104010964