1007 Maximum Subsequence Sum (25 points) (pit, and the largest sub-segment)

https://pintia.cn/problem-sets/994805342720868352/problems/994805514284679168

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

 And the maximum output and the number of sub-segments across it

When the largest sub-segment, and the output is not unique leftmost

Idea: Let initial ans as a negative number, so that when there is a time sequence of non-negative, then ans will be updated into a non-negative

If the last ans is negative, then the sequence necessarily all negative, can be output in accordance with the meaning of problems

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
int a[10005];
int main(){
    int n;
    cin>>n;
    for(int i=1;i<=n;i++) cin>>a[i];
    ll ans=-1;
    ll cnt=0;
    int L=1,R=n,l=1,r=1;
    for(int i=1;i<=n;i++){
    	r=i;
    	cnt+=a[i];
    	if(cnt>ans){
    		L=l,R=r;
    		ans=cnt;
		}
    	if(cnt<0){
    		cnt=0;
    		l=i+1;
    		r=i+1;
		} 
	}
	if(ans<0) cout<<0<<" "<<a[1]<<" "<<a[n]<<endl;
    else cout<<ans<<" "<<a[L]<<" "<<a[R]<<"\n";
	return 0;
}





 

Published 415 original articles · won praise 47 · views 40000 +

Guess you like

Origin blog.csdn.net/qq_42936517/article/details/101933302
Recommended