dp (dynamic optimal path planning of + dfs)

http://acm.hdu.edu.cn/showproblem.php?pid=1078

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17910    Accepted Submission(s): 7619


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 

 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

 

Sample Output
37
 Meaning of the questions: from (0,0) to go up and down every time the starting step, each 1-k can take the time to stop and eat cheese, seeking the maximum number of cheese you can eat.
//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <stdio.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string.h>
#include <vector>
#define ME(x , y) memset(x , y , sizeof(x))
#define SF(n) scanf("%d" , &n)
#define rep(i , n) for(int i = 0 ; i < n ; i ++)
#define INF  0x3f3f3f3f
#define mod 998244353
#define PI acos(-1)
using namespace std;
typedef long long ll ;
int a[109][109] ;
int dp[109][109];
int dir[4][2] = {{1 , 0} , {-1 , 0} , {0 , 1} , {0 , -1}};
int n , k ;

you DFS ( you get, you y)
{
    IF (DP [X] [Y]) // avoid repetition assignment, to reduce the time 
        return DP [X] [Y];
    dp[x][y] = a[x][y] ;
    for(int i = 0 ; i < 4 ; i++)
    {
        for(int j = 1 ; j <= k ; j++)
        {
            int nx = x + dir[i][0]*j ;
            int ny = y + dir[i][1]*j ;
            if(nx >= 0 && nx < n && ny >= 0 && ny < n)
            {
                if(a[nx][ny] > a[x][y])
                {
                    dp[x][y] = max(dp[x][y] , dfs(nx , ny) + a[x][y]);
                }
            }
        }

    }
    return dp[x][y] ;
}

int main ()
{
    while(~scanf("%d%d" , &n , &k) && (n != -1 || k != -1))
    {
        memset(dp , 0 , sizeof(dp));
        for(int i = 0 ; i < n ; i++)
        {
            for(int j = 0 ; j < n ; j++)
            {
                scanf("%d" , &a[i][j]);
            }
        }
        cout << dfs(0 , 0) << endl ;
    }
    return 0 ;
}

 

Guess you like

Origin www.cnblogs.com/nonames/p/11779711.html