[Poj 3150] Cellular Automaton matrix

Disclaimer: This article is a blogger original article, follow the CC 4.0 BY-SA copyright agreement, reproduced, please attach the original source link and this statement.
This link: https://blog.csdn.net/ALPS233/article/details/51558103

Topic : http://poj.org/problem?id=3150

Cellular Automaton binary matrix multiplication +

Cellular Automaton

Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 3544 Accepted: 1428
Case Time Limit: 2000MS

Description

A cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers n, m, d, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n⁄2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m − 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input
sample input #1
5 3 1 1
1 2 2 1 2

sample input #2
5 3 1 10
1 2 2 1 2

Sample Output
sample output #1
2 2 2 2 1

sample output #2
2 0 0 2 2

The meaning of problems :
there are n number of a ring, it defines a method of operating it and the distance d is smaller than the sum of the number of modulo m. Each operation refresh all data. After asking k times will become what number?

Idea :
it is easy to think of a matrix structure 01, ksm solving, n too little optimization: find a regular matrix
:
1100001
1110000
0.111 million
.. . . .
Only need to keep the line of the first row, the multiplication is calculated as follows

 for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
      c[i]+=a[j]*b[i>=j?(i-j):(n+i-j)];

Code :

#include<iostream>
#include<stdio.h>
using namespace std;
int n,m,d,k;
long long init[505],tmp[505];
void mul(long long a[],long long b[])
{
      long long c[505];
      for(int i=0;i<n;i++)
      c[i]=0;
      for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
      c[i]+=a[j]*b[i>=j?(i-j):(n+i-j)];
      for(int i=0;i<n;i++)
      b[i]=c[i]%m;                     
}
int main()
{
    int i,j;
    scanf("%d%d%d%d",&n,&m,&d,&k);
    for(i=0;i<n;++i)scanf("%lld",&init[i]);
    for(tmp[0]=i=1;i<=d;++i)tmp[i]=tmp[n-i]=1;
    while(k)
    {
            if(k&1)
            mul(tmp,init);
            k>>=1;
            mul(tmp,tmp);

    }
    for(i=0;i<n;i++)
    printf("%lld ",init[i]);
    printf("\n");
}

Guess you like

Origin blog.csdn.net/ALPS233/article/details/51558103