LightOJ 1030 Discovering Gold (probability / desired DP)

Topic links: LightOJ - 1030

Description

You are in a cave, a long cave! The cave can be represented by a \(1 \times N\) grid. Each cell of the cave can contain any amount of gold.

Initially you are in position \(1\). Now each turn you throw a perfect \(6\) sided dice. If you get \(X\) in the dice after throwing, you add \(X\) to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the \(N^{th}\) position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer \(T (≤ 100)\), denoting the number of test cases.

Each case contains a blank line and an integer \(N (1 ≤ N ≤ 100)\) denoting the dimension of the cave. The next line contains \(N\) space separated integers. The \(i^{th}\) integer of this line denotes the amount of gold you will get if you come to the \(i^{th}\) cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than \(1000\).

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than \(10^{-6}\) will be ignored.

Sample Input

3

1
101

2
10 3

3
3 6 9

Sample Output

Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15

Solution

The meaning of problems

There \ (N \) grid, each grid value is \ (val [i] \) of gold, a first grid at the initial you.

Every throw a (6 \) \ dice face, thrown into the number \ (X_i \) , will go forward \ (X_i \) grid, the grid if more than \ (N \) , then re-cast, go the lattice \ (N \) is over. Seeking to get the value of gold expectations.

Thinking

You can use probability DP or DP expect to solve.

Probability DP

Calculated the probability of each grid is reached, and then multiplied by the value of each grid tired together on the line.

Set \ (dp [i] \) of the lattice \ (I \) probability, the \ (dp [i + j] = dp [i + j] + dp [i] / k \ (1 \ le j \ K Le, \ K = min (. 6, n-- I)) \) .

DP expected

Set \ (dp [i] \) of a lattice \ (I \) to \ (N \) can be obtained the desired gold, the \ (DP [N] = Val [N] \) .

State transition equation is \ (DP [I] = \ FRAC. 1 {{}} K \ sum_. 1} ^ {KDP J = [I + J] \ (K = min (. 6, n-- I)) \) .

Code

Probability DP

#include <bits/stdc++.h>
using namespace std;
const int maxn = 110;

int v[maxn];
double dp[maxn];

int main() {
    int T;
    scanf("%d", &T);
    int kase = 0;
    while(T--) {
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; ++i) {
            scanf("%d", &v[i]);
        }
        memset(dp, 0, sizeof(dp));
        dp[1] = 1.0;
        for(int i = 1; i <= n; ++i) {
            int k = min(6, n - i);
            for(int j = 1; j <= k; ++j) {
                dp[i + j] += dp[i] * 1.0 / k;
            }
        }
        double ans = 0.0;
        for(int i = 1; i <= n; ++i) {
            ans += dp[i] * v[i];
        }
        printf("Case %d: %.7lf\n", ++kase, ans);
    }
    return 0;
}

DP expected

#include <bits/stdc++.h>
using namespace std;
const int maxn = 110;

int v[maxn];
double dp[maxn];

int main() {
    int T;
    scanf("%d", &T);
    int kase = 0;
    while(T--) {
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; ++i) {
            scanf("%d", &v[i]);
        }
        memset(dp, 0, sizeof(dp));
        dp[n] = v[n];
        for(int i = n - 1; i >= 1; --i) {
            dp[i] = v[i];
            int k = min(6, n - i);
            for(int j = 1; j <= k; ++j) {
                dp[i] += dp[i + j] * 1.0 / k;
            }
        }
        printf("Case %d: %.7lf\n", ++kase, dp[1]);
    }
    return 0;
}

Guess you like

Origin www.cnblogs.com/wulitaotao/p/11668096.html