A - QQpet exploratory park HDU - 1493 DP

 
Today, more and more people begin to raise a QQpet. You can get a lot of pleasure from it, although it does not have a real life and it calls for huge patience to take care of it. There is a place called QQpet exploratory park in the world. Every week, you can get a chance to have a joy there for free. The whole park contains 61 grids in a line, numbered from 0 to 60. Ten of them are important grids which will touch off ( 引发 ) an incident when the pet stands on. They are 5, 12, 22, 29, 33, 38, 42, 46, 50 and 55. Your pet is standing on the gird of number 0 in the beginning. You can toss the die ( 掷骰子 ) 10 times. Each time, the pet goes ahead n steps which n is the number from the die ( n ∈{ 1, 2, …, 6 } ). If your RP is great enough( calls RPG for short ), you will get many surprises in the important grids, such as some yuanbao( the money in QQpet world ), an improvement of your pet's ability, and the most attractive gift-package. Now, your task is to calculate the probability(概率) of touching each important grid.



InputThe first line of the input contains an integer t– determining the number of datasets. Then t lines follows. Each line contains 6 numbers pi, i ∈{ 1, 2, …, 6 }, indicating the probability of getting 1 to 6 after you toss the die every time . p1+ p2+ … + p6 = 1.
OutputFor each test case, output the probability of touching each important grid. accurate up to 1 decimal places. There is a blank line between test cases. See the Sample Output to get the exactly output format.
Sample Input
2
0.000 1.000 0.000 0.000 0.000 0.000
0.500 0.000 0.000 0.000 0.000 0.500
Sample Output
5: 0.0% 
12: 100.0% 
22: 0.0% 
29: 0.0% 
33: 0.0% 
38: 0.0% 
42: 0.0% 
46: 0.0% 
50: 0.0% 
55: 0.0% 

5: 3.1% 
12: 30.5% 
22: 27.3% 
29: 24.6% 
33 is: 21.9% 
38 is: 10.9% 
42 is: 0.8% 
46 is: 0.0% 
50: 4.4% 
55: 1.0% 

OJ-ID:
HDU-1493

author:
Caution_X

DATE of submission:
20.19093 million

Tags:
probability of the DP

Description modelling:
throwing the dice 10, points are given the probability of throw, throwing asked after 5, 12, 22, 29, 33, 38, 42, 46, 50, 55 points on the probability falls.

major steps to solve it:
probability = j th invested in the i-th cell, p []:: 1.dp [ i] [j] = probability of each point
2.dp [i] [1] = p [ i];
3.dp[i+k][j+1]+=dp[i][j]*p[k];

AC CODE:
#include<bits/stdc++.h>
using namespace std;
double p[7];
double dp[70][15];
int a[10]={5,12,22,29,33,38,42,46,50,55};
int main()
{
    //freopen("input.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--) {
        
        for(int i=1; i<=6; i++) {
            scanf("%lf",&p[i]);
        }

        memset(dp,0,sizeof(dp));
        for(int i=1;i<=6;i++){
            dp[i][1]=p[i];
        }
        
        for(int j=1; j<=10; j++) {
            for(int i=1; i<=60; i++) {
                for(int k=1; k<=6; k++) {
                    dp[i+k][j+1]+=dp[i][j]*p[k];
                }
            }
        }
         
        for(int i=0; i<10; i++) {
            double ans=0;
            for(int j=1;j<=10;j++){
                ans+=dp[a[i]][j]; 
            }
            printf("%d: %.1f%%\n",a[i],ans*100);
        }
        if(t)    printf("\n");
        
    }
    return 0;
}
View Code

 







Guess you like

Origin www.cnblogs.com/cautx/p/11612425.html