hdu 3974 Assign the task (the segment tree dfs sequence)

Problem Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

 

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

 

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

 

Sample Input

1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

 

Sample Output

Case #1: -1 1 2

Ideas:

The establishment of tree line on the dfs order problem into a tree can range between a few problems we can find a point of order dfs is his son node so fundamental problem is transformed into the interval with a single point of inquiry of the new +

#include <bits/stdc++.h>
using namespace std;
const double pi = acos(-1.0);
const int N = 5e4+7;
const int inf = 0x3f3f3f3f;
const double eps = 1e-6;
typedef long long ll;
const ll mod = 1e9+7;
struct edge{
    int next,v;
};
edge e[N<<1];
int head[N],cnt,tot,L[N],flag[N],R[N];
void init(){
    cnt=0;
    tot=0;
    memset(head,0,sizeof(head));
    memset(flag,0,sizeof(flag));
}
void add(int u,int v){
    e[++cnt]=edge{head[u],v};
    head[u]=cnt;
}
void dfs(int u){
    L[u]=++tot;
    for(int i=head[u];i;i=e[i].next){
        int v=e[i].v;
        dfs(v);
    }
    R[u]=++tot;
}
struct tree{
    int l,r,v,lazy;
}t[N<<2];
void build(int p,int l,int r){
    t[p].l=l; t[p].r=r; t[p].v=-1; t[p].lazy=0;
    if(l==r) return ;
    int mid=(l+r)>>1;
    build(p<<1,l,mid);
    build(p<<1|1,mid+1,r);
}
void pushdown(int p){
    if(t[p].lazy){
        t[p<<1].v=t[p].lazy;
        t[p<<1|1].v=t[p].lazy;
        t[p<<1].lazy=t[p].lazy;
        t[p<<1|1].lazy=t[p].lazy;
        t[p].lazy=0;
    }
}
void update(int p,int l,int r,int v){
    if(l<=t[p].l&&t[p].r<=r){
        t[p].lazy=v;
        t[p].v=v;
        return ;
    }
    pushdown(p);
    int mid=(t[p].l+t[p].r)>>1;
    if(l<=mid) update(p<<1,l,r,v);
    if(r>mid) update(p<<1|1,l,r,v);
}
int query(int p,int x){
    if(t[p].l==t[p].r&&t[p].l==x){
        return t[p].v;
    }
    pushdown(p);
    int mid=(t[p].l+t[p].r)>>1;
    int res;
    if(x<=mid) res=query(p<<1,x);
    else res=query(p<<1|1,x);
    return res;
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0); cout.tie(0);
    int t; cin>>t;
    int w=0;
    while(t--){
        cout<<"Case #"<<++w<<":"<<endl;
        init();
        int n,m; cin>>n;
        for(int i=1;i<n;i++){
            int u,v; cin>>u>>v;
            add(v,u);
            flag[u]=1;
        }
        int s;
        for(int i=1;i<=n;i++)
            if(!flag[i]){
                s=i; break;
            }
        dfs(s);
        build(1,1,n<<1);
        cin>>m;
        for(int i=1;i<=m;i++){
            char op; cin>>op;
            if(op=='C'){
                int x; cin>>x;
                cout<<query(1,L[x])<<endl;
            }else{
                int x,y; cin>>x>>y;
                update(1,L[x],R[x],y);
            }
        }
    }
}
View Code

 

Guess you like

Origin www.cnblogs.com/wmj6/p/11431924.html