HDU 1087 Super Jumping! Jumping! Jumping! (Dynamic programming, the maximum rise and subsequence)

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59516    Accepted Submission(s): 27708

 

Problem Description

 

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

 


Input

 

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.


Output

 

For each case, print the maximum according to rules, and one line one case.

 


Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

Topic effect and analysis

Every time you give a number n followed by n the number of representatives size pieces, each piece from the first start, jump to the last, every time a big jump compared to the previous piece, ask to skip the pawn and how much is maximum

Face questions write so much, in fact, the biggest increase in demand and subsequence, the longest sub-rise template sequence change it enough.

Code

#include<bits/stdc++.h>

using namespace std;

int a[1005],dp[1005],i,n,len,anss,j;

int main()
{
    while(scanf("%d",&n),n!=0)
    {
        len=0;
        anss=0;
        for(i=0;i<n;i++)
        {
            cin>>a[i];
            dp[i]=a[i];
        }
        for(i=1;i<n;i++)
        {    
            for(j=0;j<i;j++)
            {
                if(a[i]>a[j])
                {
                    dp[i]=max(dp[i],dp[j]+a[i]);
                }
            }
        }
        for(i=0;i<n;i++)
        {
            anss=max(anss,dp[i]);
        }
        cout<<anss<<endl;
        
    }
}

 

 

Guess you like

Origin www.cnblogs.com/dyhaohaoxuexi/p/11392061.html