Publication bias Find a multiple POJ - 2356

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2 
2 
. 3 

ideas: playing table must have found solutions for some interval
prefix and what is found to satisfy the conditions s [i]% n == s [j]% n (*)
and because there is n 0 to n + 1 number
However, the answer to the prefix 0 and n-1 to have the number n
so and there must satisfy two prefixes (*) conditions
of violence to
code:
//
#include<iostream>
using namespace std;
int n;
#define maxnn 20000
int sum[maxnn];
int a[maxnn];
int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>a[i];
        sum[i]=(sum[i-1]+a[i])%n;
    }
    for(int i=1;i<=n;i++)
        for(int j=i;j<=n;j++)
        {
            if(sum[i-1]==sum[j])
            {
                cout<<j-i+1<<endl;
                for(int k=i;k<=j;k++)
                {
                    cout<<a[k]<<endl;
                }return 0;
            }
        }
    
    
}

 



Guess you like

Origin www.cnblogs.com/OIEREDSION/p/11308385.html