Brackets (section DP)

Brackets (section DP)

topic

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6

The meaning of problems

The most number of brackets can be matched to the output

Thinking

Launched a number of inter-cell large range of the number of brackets

  1. For inter-cell, if it is possible to match the end- dp [i] [j] = dp [i + 1] [j-1] +2 because it is the most straightforward.
  2. But this is not the most accurate.
  3. For () () for dp [2] [3] = 0 because ) ( not match with that of a calculated dp [1] [4] = 0 + 2 = 2 is wrong, which should be equal to 4 .
  4. So this should be sub-scanning interval. The actual maximum should be
    dp [1] [4] = max (dp [1] [4], dp [1] [2] + dp [3] [4]) = 4

answer

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int d[105][105];

int main()
{
    char s[105];
    while (scanf("%s", s + 1), s[1] != 'e')
    {
        memset(d, 0, sizeof d);
        int len = strlen(s + 1);
        //先枚举小区间,因为后面计算大区间时需要使用小区间
        for (int l = 0; l <= len; l++)
        {
            for (int i = 1; i + l - 1 <= len; i++)
            {
                int j = l + i - 1;
                //基本的状态转移
                if ((s[i] == '(' && s[j] == ')') || (s[i] == '[' && s[j] == ']'))
                {
                    d[i][j] = d[i + 1][j - 1] + 2;
                }
                //为了找到真正最大的值,进行扫描。
                for (int k = i; k < j; k++) 
                {
                    d[i][j] = max(d[i][j], d[i][k] + d[k + 1][j]);
                }
            }
        }
        cout << d[1][len] << endl;
    }
}

Guess you like

Origin www.cnblogs.com/tttfu/p/11291003.html