POJ - 3186 Treats for the Cows(dp)

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
 
Meaning of the questions: Each can be taken from both ends of a number of assumptions made number is x, this is the first time i get, then get the value of i * x, the greatest value is finally ask how much.
. . . Set dp [i] [j] shown on the left to the i, j the right to take a maximum value is obtained, then there is the state transition equation:
dp[i][j] = max(dp[i - 1][j] + val[i] * (i + j), dp[i][j - 1] + val[n - j + 1] * (i + j))
And set the initial state dp [i] [0] (i from 1 to n), dp [0] [j] (j from 1 to n)
 
#include<cstdio>
#include<iostream>
#include<algorithm>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

const int maxn = 2e3 + 10;
int dp[maxn][maxn];
int a[maxn];

int main() {
    int n;
    while(~scanf("%d",&n)){
        for(int i = 1;i <= n;++ i)
            scanf("%d",&a[i]);
        dp[1][0] = a[1];
        dp[0][1] = a[n];
        rep(i,2,n + 1) dp[i][0] = dp[i - 1][0] + a[i] * i;
        rep(i,2,n + 1) dp[0][i] = dp[0][i - 1] + a[n - i + 1] * i;
        for(int i = 1;i <= n;++ i)
            for(int j = 1;j <= n;++ j)
                dp[i][j] = max(dp[i - 1][j] + a[i] * (i + j),dp[i][j - 1] + a[n - j + 1] * (i + j));
        int ans = 0;
        for(int i = 0;i <= n;++ i)
            ans = max(ans,dp[i][n - i]);
        cout << ans << endl;
    }
    return 0;
}

 

Guess you like

Origin www.cnblogs.com/rookie-acmer/p/11258352.html