HDU 3642 to calculate the volume intersection

Get The Treasury

Topic Link

http://acm.hdu.edu.cn/showproblem.php?pid=3642

Problem Description

Jack knows that there is a great underground treasury in a secret region. And he has a special device that can be used to detect treasury under the surface of the earth. One day he got outside with the device to ascertain the treasury. He chose many different locations on the surface of the earth near the secret region. And at each spot he used the device to detect treasury and got some data from it representing a region, which may contain treasury below the surface. The data from the device at each spot is six integers x1, y1, z1, x2, y2 and z2 (x1<x2, y1<y2, z1<z2). According to the instruction of the device they represent the range of x, y and z coordinates of the region. That is to say, the x coordinate of the region, which may contain treasury, ranges from x1 to x2. So do y and z coordinates. The origin of the coordinates is a fixed point under the ground.
Jack can’t get the total volume of the treasury because these regions don’t always contain treasury. Through years of experience, he discovers that if a region is detected that may have treasury at more than two different spots, the region really exist treasure. And now Jack only wants to know the minimum volume of the treasury.
Now Jack entrusts the problem to you.

Input

The first line of the input file contains a single integer t, the number of test cases, followed by the input data for each test case.
Each test case is given in some lines. In the first line there is an integer n (1 ≤ n ≤ 1000), the number of spots on the surface of the earth that he had detected. Then n lines follow, every line contains six integers x1, y1, z1, x2, y2 and z2, separated by a space. The absolute value of x and y coordinates of the vertices is no more than 106, and that of z coordinate is no more than 500.

Output

For each test case, you should output “Case a: b” in a single line. a is the case number, and b is the minimum volume of treasury. The case number is counted from one.

Sample Input

    2
    1
    0 0 0 5 6 4
    3
    0 0 0 5 5 5
    3 3 3 9 10 11
    3 3 3 13 20 45

Sample Output

    Case 1: 0
    Case 2: 8

The meaning of problems

Give you some cube, find the intersection of three or more and volume.

answer

Area yesterday made a demand to pay twice or more, today upgraded, in fact, better pay three times, and twice over pay is not much, but the volume of a sphere I was a bit muddled, like a long time, do not know supposed to.

The final solution to a problem to see results. . . This is not a violent feeling it? An extra dimension z, z-ordering first, then each time comprising z [I] to z [i + 1] is added to a snack cubes queue, find the area and the cubes, multiplied by the (z [ i + 1] -z [i]).

In this case you can too, and that in fact no difference between the two-dimensional, nothing more than code for more than a few, are routine ah!

Code

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define INF 0x7f7f7f7f
#define N 1050
ll kthx[N<<1],kthz[N<<1];
template<typename T>void read(T&x)
{
    ll k=0; char c=getchar();
    x=0;
    while(!isdigit(c)&&c!=EOF)k^=c=='-',c=getchar();
    if (c==EOF)exit(0);
    while(isdigit(c))x=x*10+c-'0',c=getchar();
    x=k?-x:x;
}
struct Query
{
    ll l,r,z1,z2,h; int id;
    bool operator<(const Query&e)const
        {return h<e.h;}
}que[N<<1],tmp[N<<1];
struct Node{int l,r,lazy;ll sum,sum2,sum3;};
struct segmentTree
{
    Node tr[N<<3];
    void push_up(int x);
    void bt(int x,int l,int r);
    void update(int x,int l,int r,int tt);
}seg;
void segmentTree::push_up(int x)
{
    ll len=kthx[tr[x].r+1]-kthx[tr[x].l];
    tr[x].sum=0;
    if (tr[x].l<tr[x].r)tr[x].sum=tr[x<<1].sum+tr[x<<1|1].sum;
    if (tr[x].lazy>=1)tr[x].sum=len;
    tr[x].sum2=0;
    if (tr[x].lazy>=2)tr[x].sum2=len;
    if (tr[x].l<tr[x].r&&tr[x].lazy==1)tr[x].sum2=tr[x<<1].sum+tr[x<<1|1].sum;
    if (tr[x].l<tr[x].r&&tr[x].lazy==0)tr[x].sum2=tr[x<<1].sum2+tr[x<<1|1].sum2;
    tr[x].sum3=0;
    if (tr[x].lazy>=3)tr[x].sum3=len;
    if (tr[x].l==tr[x].r)return;
    if (tr[x].lazy==2)tr[x].sum3=tr[x<<1].sum+tr[x<<1|1].sum;
    if (tr[x].lazy==1)tr[x].sum3=tr[x<<1].sum2+tr[x<<1|1].sum2;
    if (tr[x].lazy==0)tr[x].sum3=tr[x<<1].sum3+tr[x<<1|1].sum3;
}
void segmentTree::bt(int x,int l,int r)
{
    tr[x]=Node{l,r,0,0,0,0};
    if(l==r)return;
    int mid=(l+r)>>1;
    bt(x<<1,l,mid);
    bt(x<<1|1,mid+1,r);
}
void segmentTree::update(int x,int l,int r,int tt)
{
    if (l<=tr[x].l&&tr[x].r<=r)
    {
        tr[x].lazy+=tt;
        push_up(x);
        return;
    }
    int mid=(tr[x].l+tr[x].r)>>1;
    if(l<=mid)update(x<<1,l,r,tt);
    if(mid<r)update(x<<1|1,l,r,tt);
    push_up(x);
}
void work()
{
    int m,numx=0,numz=0;
    ll ans=0;
    read(m);
    for(int i=1;i<=m;i++)
    {
        ll x1,y1,z1,x2,y2,z2;
        //scanf("%lld%lld%lld%lld%lld%lld",&x1,&y1,&z1,&x2,&y2,&z2);
        read(x1); read(y1); read(z1); read(x2); read(y2); read(z2);
        que[i]={x1,x2,z1,z2,y1,1};
        que[i+m]={x1,x2,z1,z2,y2,-1};
        kthx[++numx]=x1;
        kthx[++numx]=x2;
        kthz[++numz]=z1;
        kthz[++numz]=z2;
    }
    sort(que+1,que+numx+1);
    sort(kthx+1,kthx+numx+1);
    sort(kthz+1,kthz+numz+1);
    numx=unique(kthx+1,kthx+numx+1)-kthx-1;
    numz=unique(kthz+1,kthz+numz+1)-kthz-1;
    for(int i=1;i<=2*m;i++)
        {
            que[i].l=lower_bound(kthx+1,kthx+numx+1,que[i].l)-kthx;
            que[i].r=lower_bound(kthx+1,kthx+numx+1,que[i].r)-kthx-1;
        }
    seg.bt(1,1,numx);
    for(int j=1;j<=numz-1;j++)
    {
        ll z1=kthz[j],z2=kthz[j+1],tp=0,now=0;
        for(int i=1;i<=2*m;i++)
            if (que[i].z1<=z1&&z2<=que[i].z2)tmp[++now]=que[i];
        for(int i=1;i<=now;i++)
            {
                seg.update(1,tmp[i].l,tmp[i].r,tmp[i].id);
                tp+=seg.tr[1].sum3*(tmp[i+1].h-tmp[i].h); 
            }
        ans+=1LL*tp*(z2-z1);
    }
    static int cas;
    printf("Case %d: %lld\n",++cas,ans);
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("aa.in","r",stdin);
#endif
    int T;
    read(T);
    while(T--)work();
}

Guess you like

Origin www.cnblogs.com/mmmqqdd/p/11247711.html