1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor
#include <string>
#include <iostream>

using namespace std;

int main()   //没有技术含量的一个 题
{
	//freopen("in.txt", "r", stdin);
	string s;
	cin >> s;

	int n1, n2, n3, N = s.length();;
	for (n2 = 3; n2 <= N; n2++)  //这个地方注意要跳出两层循环  用了goto语句
	{
		for (n1 = 1; n1 <= n2; n1++)
		{
			if (2 * n1 + n2 - 2 == N)
			{
				goto output;
			}
		}
	}

output:
	for (int i = 0; i < n1 - 1; i++)
	{
		cout << s[i];
		for (int i = 0; i < n2 - 2; i++)
		{
			cout << " ";
		}
		cout << s[N - i - 1]<<endl;
	}
	for (int i = n1 - 1; i <= N - n1; i++)
	{
		cout << s[i];
	}
	//fclose(stdin);
	return 0;
}

 

Guess you like

Origin blog.csdn.net/haohao0626/article/details/92318112