Class 1103 Integer Factorization (dfs + pruning)

1103 Integer Factorization (30 分)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

This question ideas:

N ranges of values ​​given by k (k <n) number of p obtained by adding the n-th power and outputs the equation (equation coefficients in descending order)

 

Use dfs and pruning:

K cycle times to find the corresponding formula 5, but when the value of n is large, a (1-n) for a large range on the loop, it is necessary pruning (unnecessary optimization determination condition) when the p-k th> cycles do not need to continue n, thus all coefficients less than n-th power into vector <int> v in

void init(){
	int temp = 0, i = 1;
	while(temp <= n){         // 系数 的p次方 范围是可以与n相等的 
		v.push_back(temp);
		temp = pow(i, p);
		i++;
	}
}

c ++ question:

1. The two vessels are equal path = pre; // path1 = pre, first deletes all of the elements of vect, then all the elements vect2

2.vector resize (), reverse, () the difference between

//https://blog.csdn.net/zjm750617105/article/details/62426843?utm_source=blogxgwz5

Use two test points for loop while loop and timeout in the topical treatment dfs (n range)

void dfs(int tempk, int sum,int sumfactor){
	if(tempk == k){
		if(sum == n && sumfactor > maxfactor){
			path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素复制给vect1, vect1和vect2的类型
			maxfactor = sumfactor;
		}
		return;
	}
	for(int i = v.size()-1; i >= 1; i--){ //i代表式子中系数的具体值  (超时)
		if(sum + v[i] > n){
			continue;
		}
		pre[tempk] = i;  //直接通过此时第K个 式子进行覆盖 并不需要在容器中一进一出 
		dfs(tempk + 1, sum + v[i], sumfactor + i);
		if(i == 1) return 
	}
}

Specific code:

#include<iostream>
#include<vector>
#include<cmath>
#include<algorithm>
//https://blog.csdn.net/zjm750617105/article/details/62426843?utm_source=blogxgwz5
using namespace std;
vector<int> pre, path, v;
int n, k, p, maxfactor = -1, tempk = 0, sum, sumfactor;
void init(){
	int temp = 0, i = 1;
	while(temp <= n){         // 系数 的p次方 范围是可以与n相等的 
		v.push_back(temp);
		temp = pow(i, p);
		i++;
	}
}

void dfs(int index, int tempk, int sum,int sumfactor){
	if(tempk == k){
		if(sum == n && sumfactor > maxfactor){
			path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素复制给vect1, vect1和vect2的类型
			maxfactor = sumfactor;
		}
		return;
	}
	while(index >= 1) {
        if (sum + v[index] <= n) {
            pre[tempk] = index;
            dfs(index, tempk + 1, sum + v[index], sumfactor + index);
        }
        if (index == 1) return;
        index--;
    }
}
//bool cmp(int a, int b){
//	return a > b; //非升序 
//}
int main(){
	scanf("%d%d%d", &n, &k, &p);
	//path.reserve(k);//
	//pre.reserve(k);	//将pre的k个长度赋值为空
	pre.resize(k);//将pre的k个长度赋值为0 io 
	init();
//	dfs(tempk, sum, sumfactor);
	dfs(v.size()-1, tempk, sum, sumfactor);
	if(maxfactor == -1){
		printf("Impossible");
		return 0;	
	} 
	printf("%d = ", n);
//	sort(path.begin(), path.end(), cmp);
	for(int i = 0; i < k; i++){
		if(i != 0)
			printf(" + ");
		printf("%d^%d", path[i], p);
	} 
	return 0;
}

 

Guess you like

Origin blog.csdn.net/qq_41698081/article/details/91346394