SDNU 1119.Intelligent NAME (水 题)

Description

We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o
7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z
When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?

Input

First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.

Output

For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.

Sample Input

1
3 5
46
64448
74
go
in
night
might
gn

Sample Output

3
2
0

Source

#include<bits/stdc++.h>
using namespace std;
#define ll long long

int t, n, m, x, id[10000+8], num[100000+8];
char c[8];

int main()
{
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        memset(id, 0, sizeof(id));
        memset(num, 0, sizeof(num));
        int sign = 0;
        for(int i = 0; i<n; i++)
        {
            scanf("%d", &x);
            id[sign++] = x;
        }
        for(int i = 0; i<m; i++)
        {
            int ans = 0;
            scanf("%s", c);
            int len = strlen(c);
            for(int i = 0; i<len; i++)
            {
                if(c[i]<='c')ans += 2;
                else if(c[i]<='f')ans += 3;
                else if(c[i]<='i')ans += 4;
                else if(c[i]<='l')ans += 5;
                else if(c[i]<='o' ) Years + = 6 ;
                else  if (c [i] <= ' s ' ) and + = 7 ;
                else  if (c [i] <= ' v ' ) + = years 8 ;
                else  if (c [i] <= ' z ' ) and + = 9 ; 
                years * = 10 ; 
            } 
            Years / = 10 ; 
            num [years] ++ ; 
        } 
        For ( int i = 0; i<n; i++)
            printf("%d\n", num[id[i]]);
    }
    return 0;
}

 

Guess you like

Origin www.cnblogs.com/RootVount/p/10981185.html