Large Division (large numbers modulo template)

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

 

Template problem, record it

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
char a[1000];
int main()
{
	int t,n,i;
	cin>>t;
	int h = 0;
	while(t--){
		ll b,ans = 0;
		cin>>a>>b;
		if(b < 0){
			b = -b;
		}
		for(i = 0; i < strlen(a); i++){
			if(a[0] == '-'){
				a[i] = '0';
			}
			ans = (ans*10+(a[i]-'0'))%b;
		}
		if(ans == 0){
			printf("Case %d: divisible\n",++h); 
		}
		else{
			printf("Case %d: not divisible\n",++h);
		}
	}
	return 0;
} 

  

Guess you like

Origin www.cnblogs.com/clb123/p/10973834.html