E - Apple Tree (Fenwick tree + DFS order)

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output
For every inquiry, output the correspond answer per line.
Sample Input
3
1 2
1 3
3
Q 1
C 2
Q 1
Sample Output
. 3 
2 Solution: Title has two actions: 1. Change the value of a node (0 ~ 1 conversion). 2. Ask a node and all its child nodes value and ownership. We can DFS re-numbered from 1, for each original node, record the number of nodes Start [i] and child nodes in the largest number End [i], we query the right to a node and all of its byte points when the sum, can use the method for finding Fenwick tree: sUM [End [I]] - sUM (the Start [I] -1).



#include<iostream>
#include<cstring>
#include<vector>
#include<string>
#include<stdio.h>
using namespace std;
typedef long long ll;
int lowbit(int x){return x&-x;}
const int maxn=100010;
int n,c[maxn];
void update(int x,int v)
{
    for(int i=x;i<=n;i+=lowbit(i))
        c[i]+=v;
}
int sum(int x)
{
    int ans=0;
    for(int i=x;i>=1;i-=lowbit(i))
        ans+=c[i];
    return ans;
}
struct node
{
    int v,next;
}e[maxn*2];
int cnt=1;
int head[maxn];
void add(int u,int v){
    e[cnt].v=v;
    e[cnt].next=head[u];
    head[u]=cnt++;
}
int tot=0;
int Start[maxn],End[maxn];
int viss[maxn];
void DFS(int x)
{
    Start[x]=++tot;
    for(int i=head[x];i!=-1;i=e[i].next){
        DFS(e[i].v);
    }
    End[x]=tot;
}
int main()
{
    memset(head,-1,sizeof(head));
    scanf("%d",&n);
    for(int i=1;i<=n-1;i++){
        int u,v;
        scanf("%d%d",&u,&v);
        add(u,v);
    }
    DFS(1);
    memset(viss,1,sizeof(viss));
    for(int i=1;i<=n;i++)c[i]=lowbit(i);
    int q;
    scanf("%d",&q);
    while(q--){
        char s[10];
        int x;
        scanf("%s%d",s,&x);
        if(s[0]=='Q'){
            printf("%d\n",sum(End[x])-sum(Start[x]-1));
        }
        else{
            if(!viss[x]){
                viss[x]=1;
                update(Start[x],1);
            }
            else{
                viss[x]=0;
                update(Start[x],-1);
            }
        }
    }
    return 0;
}

 

Guess you like

Origin www.cnblogs.com/cherish-lin/p/10960889.html