the number of specific characters in the string

question

1093 Count PAT’s (25 分)
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
5
characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input: No blank line at the end of
APPAPT Sample Output: 2


train of thought

Count the number of P on the left and T on the right of each A character. They are respectively stored in the arrays P[] and T[], and finally traverse the entire string to find A. The sum of P[j]*T[j] of all A is the answer.

the code

#include<bits/stdc++.h>
using namespace std;
const int maxn = 100010;
int main(){
    
    
    string str;
    cin>>str;
    int P[maxn],T[maxn],Pcount = 0,Tcount = 0;
    long long ans=0;
    for (int i = 0; i < str.length(); ++i) {
    
    
        if(i==0){
    
    
            if(str[i]=='P')
                Pcount++;
            P[i] = 0;
            continue;
        }
        if(str[i] == 'P'){
    
    
            P[i] = Pcount++;;
        }
        else{
    
    
            P[i] = Pcount;
        }
    }
    for (int i = str.length()-1; i >= 0; --i) {
    
    
        if(i==str.length()-1){
    
    
            if(str[i]=='T')
                Tcount++;
            T[i] = 0;
            continue;
        }
        if(str[i] == 'T'){
    
    
            T[i] = Tcount++;;
        }
        else{
    
    
            T[i] = Tcount;
        }
    }
    for (int j = 0; j < str.length(); ++j) {
    
    
        if(str[j]=='A'){
    
    
            ans = ans+P[j]*T[j];
        }
    }
    cout<<ans%1000000007;
    return 0;
}

Summarize

In particular, it should be noted that the result is modulo 1000000007, so the ans variable should be set to long long. Three for single-layer loops are used in the algorithm, and the time complexity is on the order of O(n).

Guess you like

Origin blog.csdn.net/qq_19272233/article/details/119464719