Easy to get started H3C wireless AC online AP 【Getting Started】

We know that H3C's latest emulator supports the configuration of wireless AC. Today, I will give a tutorial on wireless AC, which you can also learn.

Today we are simulating a Layer 2 environment. The author has prepared 2 APs to show how the AP goes online to the AC, and uses a mobile phone to test that the WiFi connection is normal, and the client can roam between APs.

One: Prepare the experimental environment

Partners who do not have an emulator installed on their computer can go to the H3C official website to download it by themselves https://www.h3c.com/cn/d_202302/1783214_30005_0.htm

After installing the emulator, we connect the device topology as shown in the figure below.

Small TIP: Bridge there, directly pull out the host host to connect to the AC, bridge to the network card of the virtual machine, then create vlanif56 on the AC and configure the IP address: 192.168.56.254, and configure SSH, which is convenient for us to configure in the CRT. [Sometimes vlanif is always DOWN, you can restart AC, and vlanif will be UP]

So everything is ready, let's start the learning journey!

Two: AC basic configuration

Idea: Configure the address of the bridge on the AC to facilitate the CRT demonstration, and create an SSH service [after the creation is complete, you can SSH 127.0.0.1 to self-test whether the SSH configuration is correct].

#
 sysname H3C-AC   //系统命名
#
vlan 56 //创建vlan56,用于桥接CRT
#
interface Vlan-interface56 //VLANIF56配置IP地址,也是CRT SSH的地址
ip address 192.168.56.254 255.255.255.0 
#
local-user admin  //创建本地用户admin
 password simple  XXXXXXXX  //创建密码,XXXX自行脑补
 service-type ssh //服务类型SSH
 authorization-attribute user-role level-15 //权限最高级
#
user-interface vty 0 4 //进入0 4 虚拟接口
authentication-mode scheme //设置认证方式为SSH
protocol inbound ssh //协议SSH
#
ssh server enable //开启SSH服务

Three: Complete the launch of the AP on the AC

Idea: We create the service vlan and management vlan of the AP respectively, and create an address pool to ensure that after the AP obtains the IP address, we perform basic configuration on the AP.

[H3C-AC]vlan 10 //创建AP管理vlan10
[H3C-AC-vlan10]quit
[H3C-AC]vlan 172 //创建AP业务vlan172
[H3C-AC-vlan172]quit
[H3C-AC]interface Vlan-interface 10  //配置vlan10网关
[H3C-AC-Vlan-interface10]ip address 10.0.0.1  24
[H3C-AC-Vlan-interface10]quit
[H3C-AC]interface Vlan-interface 172 //配置vlan172网关
[H3C-AC-Vlan-interface172]ip address 172.16.1.1 24
[H3C-AC-Vlan-interface172]quit
[H3C-AC]dhcp  enable  //开启DHCP服务
[H3C-AC]dhcp  server ip-pool vlan10 //创建地址池,名为vlan10
[H3C-AC-dhcp-pool-vlan10]network 10.0.0.0 mask  255.255.255.0
[H3C-AC-dhcp-pool-vlan10]gateway-list 10.0.0.1 
[H3C-AC-dhcp-pool-vlan10]expired day 15 //地址池租期15天
[H3C-AC-dhcp-pool-vlan10]quit
[H3C-AC]dhcp  server ip-pool vlan172//创建地址池,名为vlan172
[H3C-AC-dhcp-pool-vlan172]network 172.16.1.0 mask  255.255.255.0
[H3C-AC-dhcp-pool-vlan172]gateway-list 172.16.1.1
[H3C-AC-dhcp-pool-vlan172]expired day 15 //地址池租期15天
[H3C-AC-dhcp-pool-vlan172]quit
[H3C-AC]

Small TIP: Let’s talk about the difference between the management vlan and the business vlan here. The management vlan means that the AP itself can obtain an IP address, which is vlan10 in our article, and the business vlan is the IP address obtained by the client after connecting to WiFi, commonly known as business network segment. In the formal production environment, it is very necessary for us to separate management and business.

Four: AP completes basic interface debugging and goes online to AC

Idea: We respectively change the interface of the AP to the corresponding management vlan, and then

#
interface GigabitEthernet1/0/0   //进入G1/0/0端口
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 10
 port trunk pvid vlan 10 //设置PVID为10,否则AP无法识别
#
interface GigabitEthernet1/0/1   //进入G1/0/1端口
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 10
 port trunk pvid vlan 10//设置PVID为10,否则AP无法识别
#
[H3C-AC]dis dhcp  server   ip-in-use   //我们使用此命令查看到AP已经正确获取到AP段地址。
IP address       Client identifier/    Lease expiration      Type
                 Hardware address
10.0.0.2         019c-d651-ad02-02     Mar 14 21:46:20 2023  Auto(C)            
10.0.0.3         019c-d657-b203-02     Mar 14 21:46:54 2023  Auto(C) 
#
wlan ap test01 model   WA6320-HCL  //我们采取手动的方式上线第一个AP,名为test01,型号是WA6320-HCL
serial-id  H3C_9c-d6-51-ad-02-00 //序列号可以在AP上使用命令dis dev manuinfo查看
quit
#
dis wlan ap all address  //简单的等待约10S,我们使用此命令后发现AP已经上线到AC

[H3C-AC]dis wlan ap all address //查询AP MAD地址和IP以及APname对应关系命令
Total number of APs : 1
Total number of connected APs : 1
Total number of connected manual APs : 1
Total number of connected auto APs : 0
Total number of inside APs : 0

AP name                          IP address                       MAC address
test01                           10.0.0.2                         9cd6-51ad-0200


第二个测试AP我们使用自动注册的方式,毕竟现网环境中不可能大量精力去一个个注册
#
wlan auto-ap enable  //开启AP自动注册功能
wlan auto-ap persistent  all //开启AP自动固化功能
#
dis wlan ap all address  //使用命令继续查看
[H3C-AC]dis wlan ap all address //我们发现,另一个AP已经自动注册,并AP名就是设备自身MAC
AP name                          IP address                       MAC address
test01                           10.0.0.2                         9cd6-51ad-0200
9cd6-57b2-0300                   10.0.0.3                         9cd6-57b2-0300

[H3C-AC]wlan auto-ap persistent  name  9cd6-57b2-0300 //固化自动注册AP,不然不可以修改名字
[H3C-AC]wlan rename-ap 9cd6-57b2-0300 test02 //修改AP名为test02
[H3C-AC]

So far, the two APs have allowed us to register to the AC in different ways.

Five: Configure the AP and test the client

Idea: If we need to configure AP on the H3C AC, we need to create a service template, then associate the service template and service vlan under the radio in the AP, and then enable the radio to complete the configuration.

[H3C-AC]wlan service-template  1 //创建服务模板1
[H3C-AC-wlan-st-1]ssid MMMM //WiFi名称设置为MMMM,密码不认证
[H3C-AC-wlan-st-1]service-template  enable  //服务模板开启
[H3C-AC-wlan-st-1]quit
[H3C-AC]
注:模板里面还有很多配置,整体限速,认证,还有隐藏热点等等,今天主要讲基础配置,后续会继续出详细教程
[H3C-AC]wlan ap test01 //进入test01 AP
[H3C-AC-wlan-ap-test01]radio 1 //进入射频1
[H3C-AC-wlan-ap-test01-radio-1]service-template  1  vlan 176 //服务模板1业务vlan172
[H3C-AC-wlan-ap-test01-radio-1]radio enable  //射频开启
[H3C-AC-wlan-ap-test01-radio-1]max-power 20 //功率拉满
[H3C-AC-wlan-ap-test01-radio-1]channel  band-width 40 //设置频宽40Mhz
This operation might cause channel change. Continue? [Y/N]:y
[H3C-AC-wlan-ap-test01-radio-1]client max-count 128 //限制最大用户接入128个
[H3C-AC-wlan-ap-test01-radio-1]channel 36 //设置信道36
然后依次类推,我们分别进入其他AP的radio1 radio2里面进行配置,配置完毕后如图所示
[H3C-AC]dis wlan ap all radio  //查看所有AP射频状态
Total number of APs: 2
Total number of connected APs: 2
Total number of connected manual APs: 2
Total number of connected auto APs: 0
Total number of connected common APs: 2
Total number of connected WTUs: 0
Total number of inside APs: 0
Maximum supported APs: 60000
Remaining APs: 59998
Total AP licenses: 60000
Local AP licenses: 60000
Server AP licenses: 0
Remaining local AP licenses: 59998 //AP可用的授权许可数
Sync AP licenses: 0

AP name                  RID State Channel          BW    Usage TxPower Clients
                                                    (MHz) (%)   (dBm)   
test01                   1   Up    36               40    0     20      0       
test01                   2   Up    6(auto)          20    0     20      0       
test02                   1   Up    36               80    0     20      0       
test02                   2   Up    11(auto)         20    0     20      0   

We went back to the emulator client and found that the AP has been online normally, and the client can also connect normally

[H3C-AC]dis wlan client //查看AP下面客户端
Total number of clients: 1

MAC address    User name            AP name               R IP address      VLAN
00e0-0402-1235 N/A                  test01                1 172.16.1.2      172 
[H3C-AC]dis wlan mobility roam-track mac-address 00e0-0402-1235
//查看MAC地址00e0-0402-1235的客户端,漫游记录
Total entries: 2
Current entries: 2
BSSID            Created at          Online time   AC IP address   RID AP name
9cd6-57b2-0310   2023-02-27 22:20:07 00h 00m 36s   127.0.0.1       1   test02        
9cd6-51ad-0210   2023-02-27 22:17:11 00h 02m 48s   127.0.0.1       1   test01        
[H3C-AC]

Drag the client to the AP on the right, and find that it can also be connected normally, and the service IP addresses before and after the AP remain unchanged, and it is even a seamless roaming at this time.

At this point, our knowledge today ends here. Of course, this is just a simple AP launch, including second-tier registration. It is not so simple in the real live network environment. I will continue to record some articles later, and the following is a preview.

One: The AC is bypassed to the 6850 switch, the management vlan is no longer set on the AC, and the option43 parameter needs to be used to register;

Two: Create an AP group and configure wireless APs in batches;

Three: AP tuning, and some practical parameter descriptions;

Four: Simple troubleshooting ideas and solutions for wireless APs.

Guess you like

Origin blog.csdn.net/NeverGUM/article/details/129250483