ISATAP tunnel configuration and verification

ISATAP tunnel configuration and verification

【Purpose】

Familiar with the concept of IPv6 ISATAP tunnel.

Master the implementation method of IPv6 and IPv4 coexistence.

Master the IPv6 ISATAP addressing rules.

Master the configuration of IPv6 ISATAP tunnels.

Verify the configuration.

【Experimental Topology】

The device parameters are shown in the table below.

equipment

interface

IP address

subnet mask

default gateway

R1

S0/0

192.168.12.1

24

N/A

Loopback 0

2000:F106:F208:1::1

64

N/A

Tunnel0

2000:f106:f208:12::

64(eui-64)

NA/A

R2

S0/0

192.168.12.2

24

N/A

Loopback 0

2000:F106:F208:2::1

64

N/A

Tunnel0

2000:f106:f208:12::

64(eui-64)

NA/A

Experimental script:

//R1

interface Serial0/0

ip address 192.168.12.1 255.255.255.0

clock rate 2000000

no shutdown

interface Loopback0

ipv6 address 2000:F106:F208:1::1/64

ipv6 enable

no shutdown

interface Tunnel0

ipv6 address 2000:f106:f208:12::/64 eui-64

ipv6 enable

tunnel source Serial0/0

tunnel mode ipv6ip isatap

exit

do show ipv6 int b
ipv6 route 2000:F106:F208:2::/64 Tunnel0 2000:F106:F208:12:0:5EFE:C0A8:C02

end

write

//R2

interface Serial0/0

ip address 192.168.12.2 255.255.255.0

clock rate 2000000

no shutdown

interface Loopback0

ipv6 address 2000:F106:F208:2::1/64

ipv6 enable

no shutdown

interface Tunnel0

ipv6 address 2000:f106:f208:12::/64 eui-64

ipv6 enable

tunnel source Serial0/0

tunnel mode ipv6ip isatap

exit

do show ipv6 int b
ipv6 route 2000:F106:F208:1::/64 Tunnel0 2000:f106:f208:12::

end

write

【Experimental debugging】

  1. View tunnel information

R1#show interfaces tunnel 0

Tunnel0 is up, line protocol is up

  Hardware is Tunnel

  MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation TUNNEL, loopback not set

  Keepalive not set

  Tunnel source 192.168.12.1 (Serial0/0), destination UNKNOWN

  Tunnel protocol/transport IPv6 ISATAP

  Fast tunneling enabled

  Tunnel transmit bandwidth 8000 (kbps)

  Tunnel receive bandwidth 8000 (kbps)

  Last input never, output 00:02:16, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/0 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     12 packets output, 1152 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

R1#

  1. show tunnel interface information

R1#show ipv6 interface tunnel 0

Tunnel0 is up, line protocol is up

  IPv6 is enabled, link-local address is FE80::5EFE:C0A8:C01

  Global unicast address(es):

    2000:F106:F208:12:0:5EFE:C0A8:C01, subnet is 2000:F106:F208:12::/64 [EUI]

  Joined group address(es):

    FF02::1

    FF02::2

    FF02::1:FFA8:C01

  MTU is 1480 bytes

  ICMP error messages limited to one every 100 milliseconds

  ICMP redirects are enabled

  ND DAD is not supported

  ND reachable time is 30000 milliseconds

R1#

  1. Ping test

R1#ping ipv6 2000:F106:F208:2::1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2000:F106:F208:2::1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/20 ms

R1#

R2#ping ipv6 2000:F106:F208:1::1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2000:F106:F208:1::1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms

R2#

[experiment details]

1. Familiar with the concept of IPv6 ISATAP tunnel:

  1. ISATAP (Intra-Site Automatic Tunnel Addressing Protocol) is an IPv6 tunneling technology used to transmit IPv6 data on an IPv4 network.
  2. ISATAP tunnels allow IPv6 nodes to access IPv6 networks through IPv4 networks and realize the coexistence of IPv6 and IPv4.

2. Master the implementation method of IPv6 and IPv4 coexistence:

  1. In the experiment, by configuring the ISATAP tunnel, the IPv6 traffic is encapsulated in the IPv4 network for transmission, and the intercommunication between IPv6 and IPv4 is realized.

3. Master the IPv6 ISATAP addressing rules:

  1. In the experiment, the IPv6 ISATAP addressing rule is used, and the IPv6 address of the Tunnel0 interface is automatically generated using the EUI-64 rule.

4. Master the configuration of IPv6 ISATAP tunnel:

  1. In the experiment, by configuring the ISATAP tunnel on routers R1 and R2, specify the source and destination addresses of the tunnel, and enable the ISATAP tunnel mode.

5. Verify the configuration:

  1. In the experiment, some debugging commands are used to verify whether the configuration of the ISATAP tunnel is successful, such as viewing tunnel information, displaying tunnel interface information, and performing a Ping test.

By completing this lab, you will gain a deeper understanding of ISATAP tunnels and be able to configure and verify the functionality and interoperability of ISATAP tunnels.

【Review and Consolidation】

When conducting ISATAP tunnel configuration experiments, the following is a detailed explanation of each knowledge point, with examples:

1.Basic knowledge of IPv6:

  1. IPv6 address format: An IPv6 address consists of 8 groups of hexadecimal numbers, and each group is represented by 4 hexadecimal numbers separated by colons. For example, 2001:0db8:85a3:0000:0000:8a2e:0370:7334.
  2. Address types: IPv6 has different address types such as unicast addresses (for point-to-point communication), multicast addresses (for one-to-many communication), and anycast addresses (for one node among many nodes).
  3. Addressing rules: IPv6 addresses are addressed according to specific rules, such as assigning globally unique IPv6 addresses to ensure global uniqueness. For example, the IPv6 address assigned to the user by the ISP.
  4. IPv6 protocol features: Compared with IPv4, IPv6 has some improvements, such as larger address space, simplified header structure and built-in security. For example, the expansion of IPv6 address space can solve the shortage of IPv4 addresses.

2. Coexistence of IPv4 and IPv6:

  1. Differences between IPv4 and IPv6: There are differences between IPv4 and IPv6 in terms of address length, address allocation, protocol features, and routing mechanisms. For example, IPv4 uses 32-bit addresses, while IPv6 uses 128-bit addresses.
  2. Coexistence method: IPv4 and IPv6 can coexist through dual protocol stacks, tunnel technology and conversion mechanisms.
  3. Dual protocol stacks: run IPv4 and IPv6 protocol stacks simultaneously on devices that support IPv6. This way, the device can handle both IPv4 and IPv6 traffic.
  4. Tunneling technology: IPv6 traffic is transmitted by encapsulating IPv6 data packets on the IPv4 network. For example, ISATAP tunnels allow the creation of IPv6 tunnels over IPv4 networks.
  5. Conversion mechanism: to achieve interoperability and conversion between IPv4 and IPv6. For example, NAT64 converts IPv6 traffic to IPv4 traffic, enabling IPv6 hosts to communicate with IPv4 hosts.

3. ISATAP tunnel concept:

  1. ISATAP Tunneling: ISATAP is a protocol that allows the creation of IPv6 tunnels over IPv4 networks. It uses IPv4 as the underlying transport protocol and allows IPv6 hosts to access IPv6 networks through IPv4 networks.
  2. Tunnel principle: ISATAP tunnel encapsulates IPv6 data packets in IPv4 data packets for transmission on IPv4 networks. After the IPv6 data packet is transmitted to the target ISATAP node in the IPv4 network, it is decapsulated into an IPv6 data packet.
  3. Tunnel function: The function of ISATAP tunnel is to expand the deployment range of IPv6, so that IPv6 hosts can connect to IPv6 network through IPv4 network.

4. ISATAP tunnel configuration:

  1. Tunnel source and destination addresses: In ISATAP tunnel configuration, you need to specify the source and destination addresses of the tunnel. The tunnel source address is the IPv4 address of the tunnel initiation node, and the tunnel destination address is the IPv4 address of the tunnel target node.
  2. Tunnel mode: When configuring an ISATAP tunnel, you need to select a tunnel mode. Common tunnel modes include IPv6-over-IPv4 and IPv6-over-IPv4-in-IPv6.
  3. Example tunnel configuration:
  • Configure the ISATAP tunnel on R1:

interface Tunnel0

tunnel source Serial0/0

tunnel mode ipv6ip isatap

  • Configure the ISATAP tunnel on R2:

interface Tunnel0

tunnel source Serial0/0

tunnel mode ipv6ip isatap

5. Routing configuration:

  1. Static routing: Configuring static routing is one way to ensure proper forwarding of tunnel traffic. Specify the destination network and next-hop address of the tunnel by adding a static route entry.
  2. Dynamic routing: Use routing protocols (such as OSPF, RIPng) for dynamic routing configuration, so that routers in the network can automatically learn and exchange routing information.
  3. Example routing configuration:
  • Configure static routing on R1:

ipv6 route 2000:F106:F208:2::/64 Tunnel0 2000:F106:F208:12:0:5EFE:C0A8:C02

  • Configure static routing on R2:

ipv6 route 2000:F106:F208:1::/64 Tunnel0 2000:F106:F208:12::

6. Configuration verification and troubleshooting:

  1. Example of viewing tunnel information:

show interfaces tunnel 0

show ipv6 interface tunnel 0

  1. Example of tunnel interface information display:

show ipv6 interface tunnel 0

  1. Ping test example:

ping ipv6 2000:F106:F208:2::1

ping ipv6 2000:F106:F208:1::1

By mastering these knowledge points and the examples in the experiment, you will be able to understand the concept of ISATAP tunnel, the method of coexistence of IPv4 and IPv6, the steps of tunnel configuration and routing configuration, and the skills of verification and troubleshooting. This knowledge will help you successfully complete the ISATAP tunnel configuration experiment and deepen your understanding of related concepts and technologies.

Guess you like

Origin blog.csdn.net/m0_63624418/article/details/131055192