A Walk Through the Forest HDU - 1142

                           A Walk Through the ForestHDU - 1142 

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.  
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.  
InputInput contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.  
OutputFor each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647  
Sample Input
5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0
Sample Output
2
4

The main idea of ​​the title: We want to go from 1 to 2 and ask how many moves we have. But we can't go further and further, that is, we choose to take this road, and we can only get closer and closer to the point 2.
Idea: We first dijsktra the shortest path from point 2 to all points, so that we can judge whether we are getting closer and closer to distance 2. Then dfs search, the path that meets the meaning of the question, when we search for point 2, we can return.

Go directly to the code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
#define P pair<int ,int >
const int maxn=1000+10;
const int INF = 0x3f3f3f3f;
int Lext[maxn],Next[maxn*200],To[maxn*200],Len[maxn*200],dis[maxn],cost[maxn];
int cnt;
void add(int u,int v,int w)
{
    Next[++cnt]=Lext[u];
    Lext[u]=cnt;
    To[cnt]=v;
    Len[cnt]=w;
}
void init()
{
    cnt=0;
    memset(Lext,-1,sizeof(Lext));
    memset(dis,INF,sizeof(dis));
    memset(cost,0,sizeof(cost));
}
void dij(int st)
{
    dis[st]=0;
    priority_queue<P,vector<P >, greater<P > >q;
    q.push(P(0,st));
    while(!q.empty())
    {
        P temp=q.top();
        q.pop();
        int x=temp.second;
        for(int i=Lext[x]; i!=-1; i=Next[i])
        {
            int y=To[i];
            int d=Len[i];
            if(dis[y]>dis[x]+d)
            {
                dis[y]=dis[x]+d;
                q.push(P(dis[y],y));
            }
        }
    }
}
int dfs(int st)
{
    //cost数组用来存一共有多少走法
    if(st==2) return 1;
    if(cost[st]) return cost[st];
    for(int i=Lext[st]; i!=-1; i=Next[i])
    {
        int y=To[i];
        if(dis[y]<dis[st])
            cost[st]+=dfs(y);
    }
    return cost[st];
}
int main()
{
    int n,m,u,v,w;
    while(scanf("%d",&n),n)
    {
        init();
        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }
        dij(2);
        cout<<dfs(1)<<endl;
    }
}
The learning algorithm requires repeated memorization. After a period of time, I didn’t tap Dij. I understood it or tapped quickly and  continued the water problem (escape) .

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=326304395&siteId=291194637