HDU 1045 Fire Net (dfs)

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13959    Accepted Submission(s): 8533


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
 
  
4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0
 

Sample Output
 
  
5
1
5
2
4
 
刚开始下标用了1开始,但是列下标是0,找了几个小时,之后还是老老实实从0开始吧。
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int n;
int maxn;
char mat[6][6];
int judge(int x,int y)
{//判断同行同列碉堡是否冲突 
	for(int i=x;i>=0;i--)
	{
		if(mat[i][y]=='*')
			return 0;
		else if(mat[i][y]=='X')
		break;
	}
	for(int i=x;i<n;i++)
	{
		if(mat[i][y]=='*')
			return 0;
		else if(mat[i][y]=='X')
		break;
	}
	for(int i=y;i>=0;i--)
	{
		if(mat[x][i]=='*')
			return 0;
		else if(mat[x][i]=='X')
		break;
	}
	for(int i=y;i<n;i++)
	{
		if(mat[x][i]=='*')
			return 0;
		else if(mat[x][i]=='X')
		break;
	}
	return 1;
}
void dfs(int a,int b,int sum)
{
	if(sum>maxn)//取最大值 
		maxn=sum;
	for(int i=b;i<n;i++)
	{
		if(mat[a][i]=='.')
		{
			if(judge(a,i)==1)
			{
				mat[a][i]='*';
				dfs(a,i,sum+1);
				mat[a][i]='.';
			}
		}
		if(i==n-1)
		{//按行依次处理‘. ’ 
			a=a+1;
			b=0;
			if(a!=n)
			dfs(a,b,sum);
			else return;
		}
	}
}
int main()
{
	while(~scanf("%d",&n)&&n)
	{
		maxn=0;
		for(int i=0;i<n;i++)
		{
			scanf("%s",mat[i]);
		}
		dfs(0,0,0);
		printf("%d\n",maxn);	
	}
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325939255&siteId=291194637