quadratic equation

Problem Description

With given integers a,b,c, you are asked to judge whether the following statement is true: "For any x, if a+bx+c=0, then x is an integer."

Input

The first line contains only one integer T(1≤T≤2000), which indicates the number of test cases.
For each test case, there is only one line containing three integers a,b,c(−5≤a,b,c≤5).

Output

or each test case, output “YES” if the statement is true, or “NO” if not.

Sample Input

3
1 4 4
0 0 1
1 3 1

Sample Output

YES
YES
NO

Hint

Source

"Inspur Cup" Shandong Province 8th ACM College Student Programming Competition (Thanks to Qingdao University of Science and Technology)

The meaning of the question: give you a logical formula, give a, b, c, so that you can judge whether this logical formula is right or wrong;

Ideas:

As long as there is x in the formula a*x*x+b*x+c==0, then x must be an integer, that is:


p   q    p->q

0   0      1
0   1      1
1   0      0

1   1      1

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		double a,b,c;
		scanf("%lf%lf%lf",&a,&b,&c);
		if(a==0&&b==0){
			if(c==0) printf("NO\n"); //When a=b=c=0, all x are matched, so it is NO
			else printf("YES\n");//c!=0, the former formula is 0, no matter what the value of the latter formula is, the result is 0
		}
		else if(a==0){
			if((-c/b)==(int)(-c/b)) printf("YES\n");
			else printf("NO\n");
		}
		else if(b*b-4*a*c>=0){
			int flag=0;
			for(int i=-5;i<=5;i++)
			   if(a*i*i+b*i+c==0) flag++;
			if(b*b-4*a*c==0&&flag==1) printf("YES\n");
			else if(b*b-4*a*c>0&&flag==2) printf("YES\n");
			else printf("NO\n");
		}
		else printf("YES\n");
	}
	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325900073&siteId=291194637