C - Dungeon Master

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
The gist of the title: There are multiple rooms in a 3D dungeon. In this dungeon, you can move in the direction of east, west, south, north, up, and down. Ask how much time it takes to walk from room S to room E in the dungeon. . Relative to the previous breadth search
This question has two more directions, up and down. You can define a three-dimensional array map[][][] to store.

Code:

#include <iostream>  
#include <stdio.h>  
#include <string.h>  
#include <queue>  
#include <algorithm>  
using namespace std;  
  
char map[35][35][35];  
int vis[35][35][35];  
int k,n,m,sx,sy,sz,ex,ey,ez;  
int to[6][3] = {{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};  
  
struct node  
{  
    int x,y,z,step;  
};  
  
int check(int x,int y,int z)  
{  
    if(x<0 || y<0 || z<0 || x>=k || y>=n || z>=m)  
        return 1;  
    else if(map[x][y][z] == '#')  
        return 1;  
    else if(vis[x][y][z])  
        return 1;  
    return 0;  
}  
  
int bfs()  
{  
    int i;  
    node a,next;  
    queue<node> Q;  
    a.x = sx,a.y = sy,a.z = sz;  
    a.step = 0;  
    vis[sx][sy][sz] = 1;  
    Q.push(a);  
    while(!Q.empty())  
    {  
        a = Q.front();  
        Q.pop();  
        if(a.x == ex && a.y == ey && a.z == ez)  
            return a.step;  
        for(i = 0; i<6; i++)  
        {  
            next = a;  
            next.x = a.x+to[i][0];  
            next.y = a.y+to[i][1];  
            next.z = a.z+to[i][2];  
            if(check(next.x,next.y,next.z))  
                continue;  
            vis[next.x][next.y][next.z] = 1;  
            next.step = a.step+1;  
            Q.push(next);  
        }  
    }  
    return 0;  
}  
  
int main()  
{  
    int i,j,r;  
    while(scanf("%d%d%d",&k,&n,&m),n+m+k)  
    {  
        for(i = 0; i<k; i++)  
        {  
            for(j = 0; j<n; j++)  
            {  
                scanf("%s",map[i][j]);  
                for(r = 0; r<m; r++)  
                {  
                    if(map[i][j][r] == 'S')  
                    {  
                        sx = i,sy = j,sz = r;  
                    }  
                    else if(map[i][j][r] == 'E')  
                    {  
                        ex = i,ey = j,ez = r;  
                    }  
                }  
            }  
        }  
        memset(vis,0,sizeof(vis));  
        int ans;  
        ans = bfs();  
        if(ans)  
            printf("Escaped in %d minute(s).\n",ans);  
        else  
            printf("Trapped!\n");  
    }  
  
    return 0;  
}  

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325888412&siteId=291194637