Question: Day of Week

Question: Day of Week

Time Limit: 1 Sec   Memory Limit: 32 MB
http://218.198.32.182/problem.php?cid=1071&pid=7

Topic description

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

enter

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

output

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

sample input

21 December 2012
5 January 2013

Sample output

Friday
Saturday
The analysis of the meaning of the question

is to input a date and ask it to be the day of the week, which can be compared with a date. I am comparing it with January 1, 1 year. This makes it easier to write

AC code

# include <stdio.h>
# include <string.h>

int qwe(int a)
{
    return a%4 == 0 && a%100 != 0 || a % 400 == 0;
}

int main(void)
{
    char month[20];
    int day, year, k, d, i, sum;
    int q[2][13] = {{0,31,28,31,30,31,30,31,31,30,31,30,31},{0,31,29,31,30,31,30,31,31,30,31,30,31}};
    char a[15][20] = {"0","January","February","March","April","May","June","July","August","September","October","November","December"};
    char b[10][20] = {"Monday","Tuesday","Wednesday","Thursday","Friday","Saturday","Sunday"};
    while (~ scanf("%d %s %d", &day, month, &year))
    {
        sum = 0;
        for (i = 1; i < year; i ++)
        {
            if (qwe(i) == 1)
            sum += 366;
            else
            sum += 365;
        }
        for (k = 1; k <= 12; k ++)
        {
            if (strcmp(month, a[k]) == 0)
            break;
        }
        d = qwe(year);
        for (i = 1; i < k; i ++)
        {
            sum += q[d][i];
        }
        sum += day;
        if (sum%7 == 0)
        printf("Sunday\n");
        else
        printf("%s\n", b[sum%7 -1]);
        
    }
    return 0;
}


Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325815658&siteId=291194637