Schrödinger's Knapsack(dp)

Schrödinger's Knapsack

Time Limit:  1 Second       Memory Limit:  65536 KB

DreamGrid has a magical knapsack with a size capacity of  called the Schrödinger's knapsack (or S-knapsack for short) and two types of magical items called the Schrödinger's items (or S-items for short). There are  S-items of the first type in total, and they all have a value factor of ; While there are  S-items of the second type in total, and they all have a value factor of . The size of an S-item is given and is certain. For the -th S-item of the first type, we denote its size by ; For the -th S-item of the second type, we denote its size by .

But the value of an S-item remains uncertain until it is put into the S-knapsack (just like Schrödinger's cat whose state is uncertain until one opens the box). Its value is calculated by two factors: its value factor , and the remaining size capacity  of the S-knapsack just after it is put into the S-knapsack. Knowing these two factors, the value  of an S-item can be calculated by the formula .

For a normal knapsack problem, the order to put items into the knapsack does not matter, but this is not true for our Schrödinger's knapsack problem. Consider an S-knapsack with a size capacity of 5, an S-item with a value factor of 1 and a size of 2, and another S-item with a value factor of 2 and a size of 1. If we put the first S-item into the S-knapsack first and then put the second S-item, the total value of the S-items in the S-knapsack is ; But if we put the second S-item into the S-knapsack first, the total value will be changed to . The order does matter in this case!

Given the size of DreamGrid's S-knapsack, the value factor of two types of S-items and the size of each S-item, please help DreamGrid determine a proper subset of S-items and a proper order to put these S-items into the S-knapsack, so that the total value of the S-items in the S-knapsack is maximized.

Input

The first line of the input contains an integer  (about 500), indicating the number of test cases. For each test case:

The first line contains three integers  and  (), indicating the value factor of the first type of S-items, the value factor of the second type of S-items, and the size capacity of the S-knapsack.

The second line contains two integers  and  (), indicating the number of the first type of S-items, and the number of the second type of S-items.

The next line contains  integers  (), indicating the size of the S-items of the first type.

The next line contains  integers  (), indicating the size of the S-items of the second type.

It's guaranteed that there are at most 10 test cases with their  larger than 100.

Output

For each test case output one line containing one integer, indicating the maximum possible total value of the S-items in the S-knapsack.

Sample Input

3
3 2 7
2 3
4 3
1 3 2
1 2 10
3 4
2 1 2
3 2 3 1
1 2 5
1 1
2
1

Sample Output

23
45
10

Hint

For the first sample test case, you can first choose the 1st S-item of the second type, then choose the 3rd S-item of the second type, and finally choose the 2nd S-item of the first type. The total value is .

For the second sample test case, you can first choose the 4th S-item of the second type, then choose the 2nd S-item of the first type, then choose the 2nd S-item of the second type, then choose the 1st S-item of the second type, and finally choose the 1st S-item of the first type. The total value is .

The third sample test case is explained in the description.

It's easy to prove that no larger total value can be achieved for the sample test cases.

思路 :

一开始没摆脱背包的束缚,还是不能深刻理解背包吧,老在纠结体积,一看体积那么大,就应该反应过来,并非传统的背包问题,其实每个题目,尤其是dp题目,万变中总有不变的地方,那就是总会有数组恰好能容下的状态表示方法。故而看到两类物品个数2000,,此处应该是关键所在。将问题简化一下,若只有一类物品,则容易想到,体积小的物品必在前面。那么实际上问题就转化为两队物品,排好队,各取前几个的问题。因而可以想到状态的表示方法:dp[i][j] 表示1队取i个物品,2队取j个物品的最优答案。显然状态转移方程dp[i][j] = max(dp[i-1][j] + v1 , dp[i][j-1] + v2);

小结:dp的题目应该从题目中给的数据量较小的变量入手,找到状态表示方法,进而找到转移方程。

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cmath>
#include <string>
#include <vector>
#include <queue>
#include <deque>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <bitset>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long ll;

const int maxn = 2e3+5;

ll a[maxn],b[maxn];
ll suma[maxn],sumb[maxn];
ll dp[maxn][maxn];

int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		 ll k1,k2,c;
		 int m,n;
		 scanf("%lld%lld%lld",&k1,&k2,&c);
		 scanf("%d%d",&m,&n);
		 for(int i = 1; i <= m ; i++)
		 {
		     scanf("%lld",&a[i]);
		 }
		 for(int j = 1; j <= n ; j++)
		 {
			 scanf("%lld",&b[j]);
		 }
		 sort(a+1,a+m+1);
		 sort(b+1,b+n+1);
		 suma[0] = sumb[0] = 0;
		 for(int i = 1; i <= m ; i++)
		 {
			 suma[i] =a[i] + suma[i-1];
		 }
		 for(int j = 1; j <= n ; j++)
		 {
			 sumb[j] =b[j] + sumb[j-1];
		 }
		 dp[0][0] = 0;
		 dp[0][1] = k2*(c-b[1]);
		 dp[1][0] = k1*(c-a[1]);
		 ll ans = max(dp[0][1],dp[1][0]);
		 for(int i = 0; i <= m; i++)
		 for(int j = 0; j <= n; j++)
		 {
			 if(i == 0 && j == 0) continue;
			 ll v1 = i > 0 ? dp[i-1][j] + (c-suma[i]-sumb[j])*k1 : 0;
			 ll v2 = j > 0 ? dp[i][j-1] + (c-suma[i]-sumb[j])*k2 : 0;
			 dp[i][j] = max(v1,v2);
			 ans = max(ans,dp[i][j]);
		 }
		 if(ans < 0) ans = 0;
		 cout << ans <<endl;
	}
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325806784&siteId=291194637