1143. Lowest Common Ancestor


1143. Lowest Common Ancestor (30)

time limit
200 ms
memory limit
65536 kB
code length limit
16000 B
Judgment procedure
Standard
author
CHEN, Yue

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line "LCA of U and V is A." if the LCA is found and A is the key. But if A is one of U and V, print "X is an ancestor of Y." where X is A and Y is the other node. If U or V is not found in the BST, print in a line "ERROR: U is not found." or "ERROR: V is not found." or "ERROR: U and V are not found.".

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.


The meaning of the question is to find the nearest common ancestor of U and V points in the BST tree as required and output them as required

We can traverse the entire table directly. Since the pre-order sequence of BST is the insertion order of elements, which is the order of depth-first search of elements, we can directly scan the entire table, which is equivalent to a deep search of the entire tree. If the current point meets the output conditions, the output will be stopped.

But then I have been wrong and I don't know why I finally referred to the code on the Internet and found that even if I found the LCA of two points, I would output U first and then V in the input order.

Hey. . . I have been looking for this mistake for a long time. PAT is not friendly to input and output at all. . .

#include<bits/stdc++.h>
using namespace std;
int a[10010];
map<int,bool>Map;
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++){ 
        scanf("%d",&a[i]);
        Map[a[i]]=1;
    }
    while(n--){
        int s,e;
        scanf("%d%d",&s,&e);
		bool fs=0,fe=0;
		fs = Map[s],fe = Map[e];
		if(fs==0&&fe==0)
			printf("ERROR: %d and %d are not found.\n",s,e);		       
		else if(fs!=0&&fe==0)
			printf("ERROR: %d is not found.\n",e); 
		else if(fs==0&&fe!=0)
			printf("ERROR: %d is not found.\n",s);        
        else{
        	int ss = s,ee=e;
        	s = min(ss,ee),e = max(ee,ss); 
        	for(int now = 1;now<=m;now++){
				if((s<a[now]&&e>a[now])){
					printf("LCA of %d and %d is %d.\n",ss,ee,a[now]);//This is the output here If the output of the modified element of s,e will lead to two tests click error
					break;
				}
				if(s==a[now]){
					printf("%d is an ancestor of %d.\n",s,e);
					break;
				}
				if(e==a[now]){
					printf("%d is an ancestor of %d.\n",e,s);
					break;
				}				
			}
		}
    }
    return 0;
}


Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325763107&siteId=291194637