POJ3468 Line segment tree template

A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 128301   Accepted: 39825
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


#include <iostream>
#include <cstdio>
using namespace std;
const int N = 100005;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long ll;
ll sum[N<<2], add[N<<2];
struct Node {
	int l, r;
	int mid() {
		return (l + r)>>1;
	}
}tree[N<<2];
void PushUp(int rt) {
	sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void PushDown(int rt, int m) {
	if (add[rt]) {
		add[rt<<1] += add[rt];
		add[rt<<1|1] += add[rt];
		sum[rt<<1] += add[rt]*(m - (m>>1));
		sum[rt<<1|1] += add[rt]*(m>>1);
		add[rt] = 0;
	}
}
void build(int l, int r, int rt) {
	tree[rt].l = l;
	tree[rt].r = r;
	add[rt] = 0;
	if (l == r) {
		scanf("%lld", &sum[rt]);
		return;
	}
	int m = tree[rt].mid();
	build(lson);
	build(rson);
	PushUp(rt);
}
void update(int c, int l, int r, int rt) {
	if (tree[rt].l == l && r == tree[rt].r) {
		add[rt] += c;
		sum[rt] += (ll)c*(r - l + 1);
		return;
	}
	if (tree[rt].l == tree[rt].r) return;
	PushDown(rt, tree[rt].r - tree[rt].l + 1);
	int m = tree[rt].mid();
	if (r <= m) update(c, l, r, rt<<1);
	else if (l > m) update(c, l, r, rt<<1|1);
	else 
	{
		update(c, l, m, rt<<1);
		update(c, m+1, r, rt<<1|1);
	}
	PushUp(rt);
}
ll query(int l, int r, int rt) {
	if (l == tree[rt].l && r == tree[rt].r) {
		return sum[rt];
	}
	PushDown(rt, tree[rt].r - tree[rt].l + 1);
	int m = tree[rt].mid();
	ll res = 0;
	if (r <= m) res += query(l, r, rt<<1);
	else if (l > m) res += query(l, r, rt<<1|1);
	else
	{
		res += query(l, m, rt<<1);
		res += query(m+1, r, rt<<1|1);
	}
	return res;
}
int main() {
	int n, m;
	while (~scanf("%d %d", &n, &m)) {
		build(1, n, 1);
		while (m--) {
			char ch[2];
			scanf("%s", ch);
			int a, b, c;
			if (ch[0] == 'Q') {
				scanf("%d %d", &a, &b);
				printf("%lld\n", query(a, b, 1));
			}
			else {
				scanf("%d %d %d", &a, &b, &c);
				update(c, a, b, 1);
			}
		}
	}

	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325597551&siteId=291194637