poj 3181 Dollar Dayz

Dollar Dayz
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8672   Accepted: 3233

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

1 @ US$3 + 2 @ US$1
1 @ US$2 + 3 @ US$1
2 @ US$2 + 1 @ US$1
5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

Source

 
The meaning of the question: Use n yuan to exchange items whose value does not exceed k, how many exchange methods are there?
Idea: dp[i][j]: The number of schemes that use the first i prices to allocate value j
则dp[i][j]=dp[i-1][j]+dp[i-1][j-i]+...+dp[i-1][j-k*i];其中k=floor(j/i)
This is still relatively slow to do directly, you can continue to simplify:
When j=ji in the above formula
dp[i][j-i]=dp[i-1][j-i]+...+dp[i-1][j-k*i];
则dp[i][j]=dp[i-1][j]+dp[i][j-i];
This way you can use one less cycle.
Also note that the data is too large and cannot be stored in long long, you can use high and low bits to store large numbers
AC code:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
typedef unsigned long long ll;
#define N_MAX 1000+20
#define K_MAX 100+20
#define MOD 100000000000000000
int n, k;
ll dp[K_MAX][N_MAX][2];
int main() {
    scanf("%d%d",&n,&k);
    dp[0][0][1] = 1;
    for (int i = 1; i <= k;i++) {
        dp[i][0][1] = 1;
        for (int j = 1; j <= n;j++) {
            if (j >= i) {
                dp[i][j][0] = dp[i - 1][j][0] + dp[i][j - i][0];
                dp[i][j][1] = dp[i - 1][j][1] + dp[i][j - i][1];
                dp[i][j][0] += dp[i][j][1] / MOD;
                dp[i][j][1] %= MOD;
            }
            else {
                dp[i][j][0] = dp[i - 1][j][0];
                dp[i][j][1] = dp[i - 1][j][1];
            }
        }
    }
    if (dp[k][n][0]) {
        cout << dp[k][n][0];
    }
    cout << dp[k][n][1]<<endl;
    return 0;
}

 

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325321554&siteId=291194637