poj2478Farey Sequence

Farey Sequence
Link: http://poj.org/problem?id=2478
Time Limit: 1000MS   Memory Limit: 65536K
     

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6 ). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
Question 9 
Meaning: Given a number n, find the number of pairwise prime numbers in the range [1,n]. (Convert to a given number n, the number of numbers smaller than n and relatively prime to n),
use the sieve method to find Euler, otherwise it will be T
#include<cstdio>
#include<cstdlib>
using namespace std;
#define ll long long 
const int M = 1000005;
ll c[M], eular[M];
void init(){
    eular[ 1 ] = 0 ;
    
    for(int i = 2; i <= M; i++)
        if(!eular[i])
            for(int j = i; j <= M; j+=i){
                if(!eular[j])eular[j] = j;
                eular[j] = eular[j] / i * (i - 1);
            }
    
}
void add(int x, ll del){
    while(x <= M){
        c [x] + = del;
        x += x&-x;
    }
}
ll sum(int x){
    ll ret = 0;
    while(x>0){
        ret + = c [x];
        x -= x&-x;
    }
    return ret;
}
int main(){
    int n;
    init();
    for(int i = 1; i <= M; i++)
        add(i, eular[i]);
    while(scanf("%d",&n) == 1){
        if(!n)break;
        printf("%lld\n",sum(n));
    }
    
}
View Code

 


Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325305854&siteId=291194637