Dijkstra's Shortest Path Algorithm Simple Template


Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int vis[1005], dis[1005], cost[1005][1005];//vis is the marking springboard point, dis is the distance between each point and the starting point, cost is the weight of the record point and the point,
int n,m,k;
void dij(int s)
{
	vis[s]=1;//Mark the point that has acted as a springboard. At the beginning, the first starting point is the springboard point
	for(int i=1;i<n;i++)
	{
		int k=1e9-1;//Set k to a very large number
		for(int j=1;j<=n;j++)
		{
			if(!vis[j] && dis[j]<k)//Find the closest point to the springboard and this point does not act as a springboard
			{
				k=dis[j]; //Update the value of k to find the closest point to the current springboard
				s=j;//Record the current springboard
			}
		}
		vis[s]=1;//Mark the current springboard, in the next search process, this springboard will not be used
		for(int i=1;i<=n;i++)
		{
			dis[i]=min(dis[i],dis[s]+cost[s][i]);//The current springboard is point s, and it is judged that the distance between each point and the starting point is the closest,
			                                     //Or the distance between the starting point and each point through the springboard is closer, this process is called relaxation
		}
	}
	cout<<dis[n];
}
intmain()
{
	int a,b,c,k,t,sum=0.0;
	memset(vis,0,sizeof(vis));//Initialize each point to 0, and assign it to 1 if it acts as a springboard
	memset(cost, 0x3f, sizeof(cost));//Initialize the distance between each two points to infinity
	cin>>m>>n;
	for(int i=1;i<=n;i++)
	{
		cost[i][i]=0;//The distance between itself and itself is 0
		dis[i]=cost[1][i];//Initialize the distance between each point and the starting point to be infinite
	}
	for(int i=1;i<=m;i++)
	{
		cin>>a>>b>>c;
		cost[a][b]=min(cost[a][b],c);//Without a square graph, the distance from point a to point b is c;
		cost[b][a]=min(cost[b][a],c);//Without a square graph, the distance from point b to point a is c;
	}
	dij (1);
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325093641&siteId=291194637