POJ2828 Buy Tickets Tree Array

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly--2006.05.28 , Zhu, Zeyuan
 
Submission address:  Buy Tickets 
 
The main idea of ​​the title: There are n people, and each person chooses a position to insert in the queue, and asks what the final sequence looks like;
 
analyze:
Going back in time: Because the last person must be standing in the place you want to occupy, it is easy to deal with it from the back to the front;
First, assume that there is no one person, and the sequence is all 1 (we will explain why later);
Then insert the last person, for example 2, he must be inserted where he wants to be, so set the place where he stands to 0, and the sequence becomes 0 1 1 1;
Then consider the penultimate person, he is going to the second position but the last person has been inserted before him, so his final position must not be in the second position;
What position is that in? The answer is: the second 1! Why, because 1 means this position has not been occupied, so he has to stand on the second unoccupied position;
To find the value of the prefix 1 we can maintain it with a tree array (that's why the initial value is 1!);
However, it is obviously unrealistic for no one to enumerate it again, and because the prefix sum satisfies the monotonicity, it is OK to directly violently divide it;
 
should be particularly well understood;
If you don't understand it, just look at the code;
Here is the code:
 
//By zZhBr
#include <iostream>
#include <cstdio> 
#include <algorithm>
using namespace std;

int n;


struct pro
{
    int pos
    int num
} pr [ 200010 ];

int ans[ 200010 ];

int tr[200010];

int lowbit(int x)
{
    return x & -x;
}

void add(int x, int y)
{
    while(x <= n)
    {
        tr[x] += y;
        x += lowbit(x);
    }
}

int sum(int x)
{
    int ans = 0;
    while(x != 0)
    {
        ans += tr[x];
        x -= lowbit(x);
    }
    return ans;
}

intmain ()
{
    while(scanf("%d", &n) != EOF)
    {
        for(register int i = 1 ; i <= n ; i ++) ans[i] = 0;
        for(register int i = 1 ; i <= n ; i ++)
        {
            scanf("%d%d", &pr[i].pos, &pr[i].num);
            add(i, 1);
        }
        
        for(register int i = n ; i >= 1 ; i --)
        {
            int p = pr[i].pos + 1;
            
            if(sum(p) == p)
            {
                ans[p] = pr[i].num;
                add(p, -1);
                continue;
            }
            
            int l = p, r = n;
            while(l  < r)
            {
                int mid = l + r >> 1;
                if(sum(mid) >= p) r = mid;
                else l = mid + 1;
            }
            
            ans[l] = pr[i].num;
            add(l, -1);
            
        }
        
        for(register int i = 1 ; i <= n ; i ++)
        {
            printf("%d ", ans[i]);
        }
        printf("\n");
        
    }
    return 0;
}
zZhBr

 

 
 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325013370&siteId=291194637