poj2318 TOYS (binary + cross product to determine the position of the point and the straight line)

TOYS
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17523   Accepted: 8343

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random.You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.
 
Analysis: The question gives m points and n-1 regions, and asks how many points there are in each region.
Use the cross product to determine which side of the line segment the point is on, and then divide it faster.
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct Node{
    int x1,y1,x2,y2;
}a[5002];
int ans[5002];
bool judge(int x,int y,int i)
{
    int t=(a[i].x2-x)*(a[i].y1-y)-(a[i].x1-x)*(a[i].y2- y);
     if (t < 0 ) return  1 ;
     else  return  0 ; // point P is to the left of line AB 
}

void search(int tx,int ty,int N)
{
    int l=0,r=N-1;
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(judge(tx,ty,mid))//在AB(mid)右边
        l=mid+1;
        else r=mid-1; 
    }
    years[l] ++ ;
}

intmain ()
{
    int N,M,x1,y1,x2,y2; // (x1,y1) is the upper left corner, (x2,y2) is the lower right corner 
    while (scanf( " %d " ,&N)&& N)
    {
        scanf("%d%d%d%d%d",&M,&x1,&y1,&x2,&y2);
        for(int i=0;i<N;i++)
        {
            scanf("%d%d",&a[i].x1,&a[i].x2);
            a[i].y1=y1;a[i].y2=y2;
        }
        memset(ans,0,sizeof(ans));
        for(int i=0;i<M;i++)
        {
            int tx, ty;
            scanf("%d%d",&tx,&ty);
            search (tx, ty, N);
        }
        for(int i=0;i<=N;i++)
        printf("%d: %d\n",i,ans[i]);
        printf("\n");
    }
    return 0;
}
View Code

 

 
 
 
 
 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324853898&siteId=291194637