(STL—map用法)HDU 1029 Ignatius and the Princess IV


The default key value of the map is sorted from small to large, and the key value that is repeatedly entered is filtered out. It is similar to the set container, except that the map has an additional map.

Key-value and mapping data can be customized

The specific implementation of the above example:
#include <map>
#include <string>
#include <iostream>
using namespace std;
int main(int argc, char* argv[])
{
 //Define the map object, there are currently no elements
 map<string,float> m;
 //Insert elements, and put the key value into the black and white tree from small to large
 m["Jack"]=98.5;
 m["Bomi"]=96.0;
 m["Kate"]=97.5;
 // traverse the elements forward
 map<string,float>::iterator it;
 for(it=m.begin();it!=m.end();it++)
 {
 //output key value and map data
 cout<<(*it).first<<" : "<<(*it).second<<endl;
 }
 return 0;
}
operation result:
Bomi: 96
Jack : 98.5
Kate : 97.5

example:

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 40654    Accepted Submission(s): 17742


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
 
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
 
  
3 5 1

AC code:

#include <map>
#include <stdio.h>
using namespace std;
intmain()
{
	int n,x,years;
	while(~scanf("%d",&n))
	{
		map<int,int> m;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&x);
			m[x]++;	
			if(m[x]>=(n+1)/2)
			years=x;
		}
	    printf("%d\n",ans);//If you find one, you can output it. The question says there is only such a special number
		/*map<int,int>::iterator it;
		for(it=m.begin();it!=m.end();it++)
		if((*it).second>=(n+1)/2)
		printf("%d\n",(*it).first);*/
	}
	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324826413&siteId=291194637