1146. Topological Order (25)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (<= 1,000), the number of vertices in the graph, and M (<= 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (<= 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
 

Straight to the point.
Code:
#include <iostream> 
#include <cstring> 
#include <cstdio> 
#include <map>
 #define Max 1005
 using  namespace std;
 int n,m,k,limit[Max],exa[Max],a,b,mp [Max][Max],ans[Max],ant; /// There are several points ahead of the limit stored in a certain point

int check()
{
    int p[Max];
    for(int i = 1;i <= n;i ++)///limit转到p
    {
        p[i] = limit[i];
    }
    for(int i = 0;i < n;i ++)
    {
        if (p[exa[i]]) /// p is positive means the order is invalid 
        {
             return  0 ;
        }
        for ( int j = 1 ;j <= n;j ++) /// If it is legal to reduce the points p restricted by it by 1 
        {
             if (mp[exa[i]][j])p[j] - - ;
        }
    }
    return 1;
}
intmain ()
{
    scanf("%d%d",&n,&m);
    for(int i = 0;i < m;i ++)
    {
        scanf("%d%d",&a,&b);
        mp [a] [b] = 1 ;
        limit[b] ++;
    }
    scanf("%d",&k);
    for(int i = 0;i < k;i ++)
    {
        for(int j = 0;j < n;j ++)
        {
            scanf("%d",&exa[j]);
        }
        if(!check())
        {
            ans[ant ++] = i;
        }
    }
    for(int i = 0;i < ant;i ++)
    {
        if(i)printf(" %d",ans[i]);
        else printf("%d",ans[i]);
    }
}

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324782011&siteId=291194637
Recommended