Nise-Anti-AK Problem

Description:

Peppa has been learning math recently, he is trapped by a easy problem. He is given a sequence of n numbers, what he need to do is finding the number ai which have the largest number f(ai). The function f(x)=∑(i|x) where i goes form 0 to x, | is the symbol of or-by-bit calculate.

Input:

The first line of the input has an integer T(1<=T<=10), which represents the number of test cases.

In each test case, the first line of the input contains an integers n(1<=n<=1000)--the number of the integers, next line has n integers a[i] (1 <= a[i] <= 10000).

Output:

Each test case output an integer ai which have the largest number f(ai). 

Ignore extra spaces at the end of each line of output

sample input

1
3
2 3 5

Sample output

To find the maximum value, you can use the max function. int mx=max(mx,num[i]); this is convenient

#include<iostream>
#include<stdio.h>
using namespace std;
int num[1007];
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        int n,mx=0;
        cin >> n;
        for(int i=0; i<n; ++i)
        {
            cin >> num[i];
            if(mx<num[i])//int mx=max(mx,num[i]);
              mx=num[i];
        }
        cout << mx <<endl;
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324708870&siteId=291194637