POJ3259 Wormholes (bellman template & detection of negative weight loops)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer,  F F  farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  N M , and  W 
Lines 2..  M +1 of each farm: Three space-separated numbers (  S E T ) that describe, respectively: a bidirectional path between  S  and  E  that requires  T  seconds to traverse. Two fields might be connected by more than one path. 
Lines  M +2..  M W +1 of each farm: Three space-separated numbers (  S E T ) that describe, respectively: A one way path from  S  to  E  that also moves the traveler back T  seconds.
Output
Lines 1..  F : For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

The meaning of the question: each set of data first gives m positive weight edges and then gives w negative weight edges, where the positive weight edges are bidirectional and the negative weight edges are unidirectional, to determine whether there is a negative weight loop.

Problem-solving idea: Bellman-Ford solves the negative weight edge.

The principle is: for a graph with n points, at most n-1 rounds of relaxation can be performed to find the shortest path. If the relaxation can continue successfully after n-1 rounds of relaxation, then the graph must have negative weights. loop.

The Bellman-Ford algorithm often computes the shortest path before reaching n-1 rounds of relaxation. Therefore, check is added to mark whether the array dis has changed in this round of relaxation. If there is no change, the relaxation is over, and the loop will be jumped out in advance.


AC code:

#include<stdio.h>
#define INF 0x3f3f3f3f

int dis[510],n,m,w;

struct edge
{
	int s,e,t;
} e[2710];

void bellman()
{
	int flag,check;
	for(int i=1;i<=n;i++)
		dis[i]=INF;
	for(int k=1;k<=n-1;k++)
	{
		check=0;
		for(int i=1;i<=m;i++)//双向路
		{
			if(dis[e[i].s]+e[i].t<dis[e[i].e])
			{
				dis[e[i].e]=dis[e[i].s]+e[i].t;
				check=1;
			}
			if(dis[e[i].e]+e[i].t<dis[e[i].s])
			{
				dis[e[i].s]=dis[e[i].e]+e[i].t;
				check=1;
			}
		}
		for(int i=m+1;i<=m+w;i++)//单向路
		{
			if(dis[e[i].s]+e[i].t<dis[e[i].e])
			{
				dis[e[i].e]=dis[e[i].s]+e[i].t;
				check=1;
			}
		}
		if(check==0) break;
	}
	flag=0;
	for(int i=1;i<=m;i++)//Determine whether there is a negative weight loop
	{
		if(dis[e[i].s]+e[i].t<dis[e[i].e]) flag=1;
	}
	if(flag) printf("YES\n");
	else printf("NO\n");
}

intmain()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&w);
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
		}
		for(int i=m+1;i<=m+w;i++)
		{
			scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
			e[i].t=-e[i].t;//Convert to negative number to indicate negative weight
		}
		bellman();
	}
	return 0;
}


Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324664564&siteId=291194637